1

I have a brand new desktop with a new SSD. So I installed my copy of Windows 8.1 on it and got it all done fine. When I first went to the desktop I thought to install a graphics card driver first. So I installed the NVIDIA 9800 GTX graphics driver for 64-bit Windows 8.1 found here.

However, when I did that the screen went black with my mouse flickering when I moved it. I waited for 4 hours and still nothing, the screen was black. I looked it up and saw that many people are having this issue with windows 8.1 getting a black screen upon updating.

I tried doing a fresh installation a 2nd time but now I ran windows update instead of installing nvidia's driver first. Everything downloaded and installed fine but then when I restarted same thing. It seems ANY update whatsoever will break this OS.

Anyone have any idea on what the problem is? Could it be a BIOS issue?

2 Answers 2

2

1st of all, try running Windows in safe mode (this article explains how to do that : http://pcsupport.about.com/od/windows-8/a/open-advanced-startup-options-windows-8.htm). After you boot in safe mode, Windows should load the default drivers for the video card.


If Windows is running in safe mode, you have a driver issue. You can try this driver (not sure if it will work - http://www.geforce.com/drivers/results/73218)


If Windows doesnt start in safe mode either, you should troubleshoot the video card to see if the problem is in the card.(You can do that by running a OS from a USB (like Ubuntu))


If you need more help, comment on this answer. I will see if I can help more.

2
  • yep this was part of the problem. I figured it out, there are mixed drivers for the graphics card. Windows wants to install its own while I have the vendor graphics drivers...they both clash and boom problem. All i have to do is uninstall window's graphics drivers, install the vendors and then do a windows update (this time it won't bother with the graphics card since it sees there's already a driver for it) and then all is good
    – Richard
    Commented Apr 17, 2014 at 17:13
  • glad I could help
    – lyubolp
    Commented Apr 18, 2014 at 17:43
1

Solution: Replacing Windows.UI.Immersive.dll file

Step 1 : go to system32 subfolder in Windows folder (typically C:\Windows\System32)

Step 2 : Find the Windows.UI.Immersive.dll,check for Date Created attribute(if it is in October 2012,you may have to replace with the recent one)

Step 3 : Goto WinSxS subfolder in Windows folder,search for Windows.UI.Immersive.dll(which is newer version) ](i found it in C:\Windows\WinSxS\x86_microsoft-windows-windowsuiimmersive_31bf3856ad364e35_6.3.9600.16408_none_c6ca1a15ef5e5709)

Step 4: Replace the older file with the newer one in system32 folder

Step 5: there is a hidden folder called Windows Activation Technologies in root drive(usually C:\Windows Activation Technologies),replace the older file in the above folder too. Then restart, hopefully this solves your problem

Source :Blank Screen after Installing Windows 8.1? - Microsoft Community http://answers.microsoft.com/en-us/windows/forum/windows8_1-windows_install/blank-screen-after-installing-windows-81/23fd21bb-4c37-4342-9b2c-5c9b396ed796?page=2

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .