1

OS: Arch Linux (systemd) UI: LXDM logging in to Openbox.

I have the following in my /etc/lxdm/PostLogin:

/usr/bin/xscreensaver -no-splash -verbose -log /var/log/xscreensaver.log -display :0.0 &

It doesn't start xscreensaver. I've tried variations on the command, with /usr/bin, without, with -display, without, without -verbose... Nothing. No log messages, nothing on dmesg, nothing.

If I run xscreensaver daemon after login, it works, but that's a hassle for something that should work just fine. Yes, the same autostarting file does get my batti and nm-applet working fine, so it's not the file, it's the program, crashing. How do I stop it from crashing?

Any advice?

Edit:

$ which xscreensaver
/usr/bin/xscreensaver
  • whats the output of which xscreensaver? – eyoung100 Apr 18 '14 at 0:34
  • /usr/bin/xscreensaver – Aviator45003 Apr 18 '14 at 0:56
  • what happens if you type /usr/bin/xscreensaver in a terminal? It should tell you xscreensaver is already running on display XX because xscreensaver is forked after X starts automatically IIRC – eyoung100 Apr 18 '14 at 0:59
  • It works. If I start the daemon after login, it works just fine, I just have to do it manually. – Aviator45003 Apr 18 '14 at 1:01
  • You shouldn't need to do it manually. This is one reason xscreensaver is a dependency of X, the screensaver runs automatically while X is running, even when its not in use... it counts the time you do nothing. If the time you do nothing = your set time the screensaver starts – eyoung100 Apr 18 '14 at 1:07
3

Turns out /var/log/xscreensaver.log was the problem: it could not be written to for ownership conflicts. I had set it as a log in .Xresources, so the problem was not obvious.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.