I'm configuring my local Apache webserver after a fresh Kubuntu 14.04 install. Apache version is 2.4.7.

I usually work with files located in a separated partition (/dev/sdb6 here), and create symbolic links into /var/www/ folder.

The fact is it does only works with symlinks pointing to /home/user/someFolder, but it doesn't with folders located on the partition. This partition is ext4, and mounted in media/user/partitionName. This directory is owned by my user, and has x permission bits for every subfolders. The user www-data is assigned to my group, and my user is assigned to group www-data.

The apache2.conf file (and all eventual other vhosts conf files) have the FollowSymLinks option for the <Directory /var/www/> directive.

What do I miss ? The weird thing is that it follows the symlinks pointing to /home/user/something... But not the ones pointing to another location. This result in a:

AH00037: Symbolic link not allowed or link target not accessible: /var/www/somelink

I even tried to add the option -SymLinksIfOwnerMatch to be sure it doesn't have to be the same user for the target (even if I know it's the same), but no change.

  • Is there any chance this partition is mounted with ACLs? Can you try suing as the webserver user and accessing these files?
    – Bob
    Commented Apr 21, 2014 at 15:19
  • Something like sudo -u www-data ls /path/to/folder or sudo -u www-data cat /path/to/file.
    – Bob
    Commented Apr 21, 2014 at 15:26
  • Yes, thanks I found out. (was sudo su - www-data -s /bin/bash). BTW, trying to access a symlinked folder results in a Permission denied. And trying to access directly to the folder: the same. However, I can just access to the /media folder, but not its content (/media/username/). I found a little + sign at the end of the permissions: drwxr-xr-x+... What does it means?
    – Polosson
    Commented Apr 21, 2014 at 15:36
  • Looks like you do have ACLs enabled: serverfault.com/questions/227852/… ACLs allow finer-grained control over permissions (allow/deny specific permissions to specific users/groups, NTFS permissions on Windows are the most common implementation).
    – Bob
    Commented Apr 21, 2014 at 15:38
  • Well you're right! Thanks a lot. Now I'll try to figure out how disable ACL for this partition, or set them up the right way. Thanks again!
    – Polosson
    Commented Apr 21, 2014 at 15:48

1 Answer 1


My first hunch would be ACLs, assuming you have the POSIX permissions already set up correctly. Check if you've mounted this partition with ACLs enabled.

If you want to do some further testing, you should su into the webserver user (www-data) and run some ls commands to see if that works. For example, sudo -u www-data ls /path/to/folder.

  • Great. Just had to run setfacl -b /media/parentFolder/. More about ACL here. Thanks a lot!
    – Polosson
    Commented Apr 21, 2014 at 16:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .