1

the title is quite explicit : I'm trying to install google's driver for my android device in order to use it for development ( I need it to be seen by 'adb devices' )

I've got a Nexus 5 and windows 7 x64

Everywhere I can read :

plug your device, go to device manager, right click on Android device, update driver and choose from disk to install google's usb-driver from the extra folder of android sdk

But when I plug my nexus 5 to my pc, nothing happen at all :( I've try several usb ports, several usb conection modes (on the phone : MTP, PTP) with usb debug enabled/disabled. there is nothing I can do.

I've also try another device : the sony xperia Z1. this one is shown as "Unknown Device" and if I try to install google's driver, it says

The driver for this hardware is up to date : "Unknown device"

I've got no lead so any advice is welcome.

EDIT : this thread from xda-developpers says "uninstall all drivers" then plug the android device...

Does anyone know how to uninstall a driver that is not showing up in wondows 7 ?

  • Maybe your phone's USB port or cable is just broken? – grawity Apr 20 '14 at 11:32
  • I've got the phone battery charging so I thought it was working fine but indeed, there is no "usb mode alert", no notification about the usb connection as it should be :/ I'll try another usb cable and let you know if it helps – Guian Apr 20 '14 at 11:40
  • 1
    AFAIK, USB 2.0 connections use two pairs of wires – one for power, one for data; I've heard of USB "charge only" cables that only have one pair and cannot carry data. (Just one more thing that makes me go "why would you sell junk like that?" but oh well.) – grawity Apr 20 '14 at 11:42
3

Ok thanks a lot to Mr grawity :)

I've manage to see the nexus 5 appear in windows 7 device manager by using another usb cable.

As you said Why the hell would someone sell usb cable with "Charge only" capability :( but we should be aware : that exists.

  • Your cable might have become broken. I just had this same issue with a cable that I knew was good in the past. – Kaypro II Aug 3 '14 at 4:06
0

I also have the same issue with my Sony Xperia Z1. I have managed this by "Installing the Device Software" in my PC

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.