8

This is urxvt without tmux

no tmux

This is urxvt with tmux and utf8 not enabled in the config

tmux with utf8 enabled

This is urxvt with tmux and utf8 enabled in the config

tmux with utf8 not enabled

How can I make tmux act consistent with the initial result?

  • Where can I get that glyphs application to test the results? – Valmiky Arquissandas Jul 25 '14 at 2:23
  • The glyphs script is from this: github.com/lucy/tewi-font/blob/master/glyphs I've actually stopped having this problem a long time ago, with no action on my part. I installed Windows 7 since posting as well. – Hal Jul 29 '14 at 7:22
2

Would you please try the following and see if it helps?

  • rename .tmux.conf to something else
  • set LANG="en_US.UTF-8"

Clarification:

I have seen the existence of ~/.tmux.conf may cause problem so just for testing I suggested to rename the file. And forcing LANG=en_US.UTF-8 is another measure to ensure the correct locale to be used (since Hal didn't supply his LANG setting(s))

  • Can you make your instructions a little more explicit? Thanks. – fixer1234 May 6 '16 at 5:50
  • 1
    @fixer1234 : I'm not meaning to endorse this, but just to elaborate on the steps. Get to a command line (Bourne shell or mostly-compatible, like bash, ought to work fine; I expect urxvt ought to work fine). Type these lines into the command prompt: First line: mv ~/.tmux.conf ~/tmux.conf.bak Second line: set LANG="en_US.UTF-8" ; Third line: tmux ; Fourth line: glyphs – TOOGAM May 9 '16 at 4:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.