The connection between my MacBook and the Qnap TS-112 is very poor. When I try to mount it, it usually says "Connection failed". When it does connect it can be very slow.

The thing I want is when I open my MacBook, the Qnap disk pops up and I can continue my work.

What am I doing wrong?

  • Could you show your export settings from Qnap and how you're trying to mount it on the Mac? – mbb Apr 21 '14 at 22:34
  • I'm not sure how to export my Qnap settings? Perhaps you can explain how to do this. What I do is, when the NAS drives appears in the left bar from finder, under shared, I click the disk to connect. Very often it says "unable to connect". But the drives not always show up in the finder. – Pierre Apr 21 '14 at 23:04
  • 1
    Do you have other devices for which it works well? Does the QNAP spin down its drives when idle? I have a TS-212 and sometimes it takes a minute or so to finally connect. Sometimes it also says "Item not found" or something. – slhck Apr 22 '14 at 8:36
  • This problem occurs to my Macbook Pro 15" Retina and my iMac late 2007. There is also a Mede8er Media player connected through UTP. This media-player plays movies from the NAS pretty well. The NAS is hardwired through UTP connected to my router. – Pierre Apr 22 '14 at 17:53

Have a look at this other superuser answer - It worked for me

OS X: How to avoid having to re-connect to network share after NAS was turned off?

I have found that my qnap interpretation of AFP is quite odd and slow in connecting. SMB works far better if you have that protocol enabled.

  • 1
    Thanks, im sure it's not OS X. On my work we're running a Synology NAS. It alway connect without any problem. It's just the Qnap which causes a headache;-) – Pierre Apr 21 '14 at 23:15

I think I have found the problem. I did connect through IP using smb://xxx.xxx.xxx.xxx. My Qnap is called SRV1. So I try to connect using smb://SRV1.

I also deleted the connection history in the "Connect to server window".

This works like a charm. Thanks all for helping me out!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.