18

Memory continuously rises, probably because of various applications that I run including Chrome, and it starts to choke out windows so I try to reboot it after 3-4 days at the most.

When I am in the Task Manager after a complete cycle (shut down and start up) it shows 5 days 7 hours 30 minutes and some seconds. Also, Memory is at 2.9 GB after a restart, is this normal?

What kind of issues is this going to cause, other than I can't tell exactly how long it has been between cycles (restarts)?

How can I fix this issue?

I am running Windows 8.1 Pro. I have been trying for about 30 minutes to search Google for this issue and possible solutions but "uptime" is quite the ambiguous word.

  • 1
    yep "uptime" is definitely ambiguous.. where do you get your uptime from? – Vogel612 Apr 22 '14 at 12:45
  • task Manager, as I said in the the question @Vogel612 – Malachi Apr 22 '14 at 12:46
  • 1
    This might sound a bit strange, but how exactly are you doing a shut down? Are you sure it is an actual shut down and not a sleep or hibernate function? If you're running Windows on laptop, instead of shutdown your default action might be to put computer on sleep, so check this out. – LightBulb Apr 22 '14 at 12:54
  • this is a full Desktop. and from the answer and the testing I did at work, it sounds like the hybrid windows 8 reboot and shutdown mechanism like what you and @Vogel612 are talking about – Malachi Apr 22 '14 at 13:35
15

This seems to be connected to what @LightBulb said. In this thread the second post mentions:

this happens becasue of the new Shutdown/Boot mechanism from Windows 8 which is basically a logoff + Hibernation. [sic]

He also links this msdn blog, where I found the following:

Of course, there are times where you may want to perform a complete shutdown – for example, if you’re opening the system to add or change some hardware. We have an option in the UI to revert back to the Windows 7 shutdown/cold boot behavior, or since that’s likely a fairly infrequent thing, you can use the new /full switch on shutdown.exe. From a cmd prompt, run: shutdown /s /full / t 0 to invoke an immediate full shutdown. Also, choosing Restart from the UI will do a full shutdown, followed by a cold boot.[highlight by me]

Summary:

Shut down does not reset the CPU cycle! If you want to reset the CPU cycle (and thus uptime), use the Restart option or run shutdown /s /full instead.
@Daniel B has provided yet another alternative. When shutting down via UI, press Shift when you click. When using that trick with "Restart", you get the "Advanced Startup Options" screen.

| improve this answer | |
  • 5
    No need for this cumbersome method. Just hold Shift while initiating the shutdown and you're done. Shift Reboot brings up the Advanced Startup Options screen. – Daniel B Apr 22 '14 at 13:11
  • 1
    first thing I did when I got to work was talk to the Network Services guy, and we did some tests on his Windows 8 laptop and found the same thing. all he had to do though was a shutdown -r -f -t 002 but he did that over the network because the laptop is connected to the work network. do you think that the "half restart" affects the memory consumption upon restart or "warm" shutdown? – Malachi Apr 22 '14 at 13:31
6

@Vogel612's answer is correct, the reason your uptime doesn't reset is because of Windows 8's new Hybrid Boot feature.

You can disable the feature, if you like. There is little reason to keep it enabled on a system with SSD, unless your SSD happens to be really slow for whatever reason.

Screenshot

  1. Go to power options (Type "power options" on the Start Screen).
  2. Click on "Choose what the power buttons do" on the left side of the window.
  3. Click on the blue link "Change settings that are currently unavailable". This allows you to change the settings.
  4. Uncheck "Turn on fast startup (recommended)" to disable Hybrid Boot.
  5. Don't forget to "Save changes".

The reason the option is marked as "recommended" is because it helps boot your PC faster. Windows 8 boots a lot faster on HDDs with this option enabled, but the difference is mostly negligible on SSDs.

| improve this answer | |
1

This CPU up time not reporting correctly is a Microsoft generated problem. I'm not sure why MS thought it was a good idea to mess with how the Kernel loads into RAM after a shutdown and not a restart, but I have a solution for all of you. Microsoft changed how the shutdown function worked starting with the Schizophrenic OS we call Windows 8 and affects windows 10 as well.

Option 1 use the command shutdown /p in CMD or RUN to do a real shutdown

Option 2 open power management and uncheck FAST BOOT at the bottom under the section "change what the power button does" (click the top link) that says "change settings that are currently unavailable" and has a UAC icon next to it.

Option 3 Change this Reg key from 1 to zero to remove the CPU up time problem

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Power]

"HiberbootEnabled"=dword:00000000

Option 4 Format your harddrive and install a real OS like Linux... I'd forgive you some if you go back to windows 7. I totally understand.

Here is more info and a breakdown of what's going on.

https://betanews.com/2016/03/03/windows-10-fast-startup/

| improve this answer | |
  • I would use Linux more often, but I use Windows for work and it seems like it would be counterproductive. I do like the idea of using .NET on Linux now as well, so I may go back to Linux. I already use Linux based OS on machines for my Children and one of my machines that I use for miscellaneous stuff. – Malachi Apr 26 '17 at 15:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.