0

So, I was playing around and decided to see if I could reset the password in single-user mode. I KNOW that I can more safely reset a user password using the recovery partition, being that this is 10.9.2, but I decided I wanted to see if I could do it in Single-User Mode if I needed to.

I did not run fsck first (because I've never really had to even on 10.5 or 10.6).

I did:

/sbin/mount -uw /

launchctl load /System/Library/LaunchDaemons/com.apple.opendirectoryd.plist

passwd username

  • So I reset the login password, which was successful.
  • Rebooted into UI
  • Logged into user account successfully
  • Finder asked me if I wanted to update the keychain, create a new keychain, or continue to login. I opted to create a new keychain, as that is what I always did in the past
  • Finder then constantly asked me for the password for the "login" keychain.
  • New password did not work, only the old password worked, strangely

As an experiment, I entered time machine, went back to yesterday (before I started messing around) and restored and replaced all items in /Users/username/Library/Keychains/ as well as /System/Library/LaunchDaemons/com.apple.opendirectoryd.plist then rebooted.

New password worked, I chose "Update keychain" at the prompt, then continued to finder. Same issue. Asked by many applications to provide the password for the login keychain. Only the old password worked. This kind of makes sense, because I'm using the old keychain files and old open directory plist.

I remedied (although maybe not totally) the issue by just changing the password using the recovery partition, then providing the old password for everything.

So I think my questions are:

1.) Where does the user or admin login password actually get stored, if not the login keychain or the open directory plist?

2.) Why would I need the old password for the login keychain if I've created a new keychain when prompted?

Just curious! Thanks!

4
  • Your information is imcomplete...please provide the OS, OS version and the platform you are running on. It looks like an Apple to me but I am not a mindreader. – mdpc Apr 22 '14 at 19:33
  • @mdpc : It's tagged OSX-Mavericks and he stated it's 10.9.2. Given the nature of his question, however, it may be better suited in the Information Security forums. – Omegacron Apr 22 '14 at 20:41
  • ...or in the Apple SE (don't know its name) – mdpc Apr 22 '14 at 21:11
  • Thanks for your responses, guys. I'm a total newbie here so feel free to point me in the right dir if need be ;) As Omegacron stated, yes, MacOs X Mavericks (10.9.2). – nuclearsalt Apr 22 '14 at 23:39
0

Go to the "go menu" at the top of your screen, select "go to folder", type ~/Library/Keychains/ and hit Enter.

Then delete everything you see in that folder, reboot, recreate a new keychain if prompted.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.