25

I am trying to install Ubuntu 14.04 alongside Windows 7. I have a 500 GB hard disk split into 3 partitions. I am installing Ubuntu from a live USB drive. But I am stuck at the "Installation type" stage. This is what I see:

enter image description here

My three partitions aren't shown. What do I do?

27

I had the same problem. Opening terminal and running the command

sudo gdisk -l /dev/sda

indicated that I have both MBR and GPT tables present. This happened because I had originally Windows 8 pre-installed on my computer. Windows 8 uses GPT scheme. I installed windows 7 over it. Windows 7 is using MBR and finally my disk end up being MBR with some stray GPT data on it.

This is a known problem and can be fixed using FixParts

fixparts /dev/sda

The program will detect the problem automatically and propose solution. More details here if you're interested.

The program is readily available within Ubuntu 14.04 live usb.

  • 2
    Thank you, this fixed the problem for me! Two comments though: 1) fixparts requires root access so I had to run it with sudo. 2) I have multiple HDs (one SSD & one data drive) so I had to run fixparts for both sda and sdb. – Jesse Webb Jan 2 '15 at 7:31
  • 1
    I am having the when installing Ubuntu alongside Windows 8.1. It is a similar case. gdisk shows both MBR and GPT. When I ran fixparts, it says that some GPT signatures were detected that were probably leftovers from a previous operating system. If I delete them, is there any risk of losing my data in windows? I already created a 40GB partition in Windows. – Alchemist Feb 1 '16 at 7:44
2

The first thing to do is to ascertain whether you disk has an all-new GPT partition table, or an old-style one. You should boot Ubuntu, choose Try Ubuntu without installing it, open a terminal, and issue this command:

  sudo fdisk -l /dev/sda

If this command generates output about being unable to read/access the disk partition table, then you have a GPT-kind partition table. In this case, the command

  sudo gdisk -l /dev/sda

should instead produce a meaningful output, without any complaint about an MBR. This is to confirm that you have a GPT partition table. If you do, you will find help on the Ubuntu Help pages

2

How to fix this issue with Ubuntu 14.04:

  1. Log on Windows
  2. Download AOMEI Partition Assistant
  3. Create a new partition
  4. Convert it to EXT3
  5. Start again the ubuntu installation
  6. It works.
1

I think your hard disk is converted to dynamic. You can verify that with Windows built in Disk management.

Now you need to convert your disk from dynamic to basic with help of the How to Convert a Dynamic Disk to a Basic Disk article on SevenForums. (I used minitool partition wizard PROFESSIONAL EDITION). I did not loose any data in this procedure. That did the trick. I faced another problem in the installation which may or may not be related. Still sharing the link: Rod's solution on Unable to satisfy all constraints on the partition when installing Ubuntu from USB at AskUbuntu is enough.

0

I had the same problem.

I Just converted my Disk from MBR to GPT and my problem solved. I used "AOMEI Partition Assistant" application for converting my Disk to GPT.

  • 4
    Can you expand your answer a little to explain how to accomplish this? You mention the general approach to the solution and a tool you used, but not how to actually solve the problem. Thanks. – fixer1234 Mar 2 '15 at 15:37

protected by Community Jun 12 '15 at 6:23

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.