1

I have a new Macbook Pro retina (late 2013 model) running Ubuntu 13.10. I can't get the sound to work. I have tried the solution here , but it's not changing anything. I also tried the following series of commands, but they don't change anything, either:

sudo apt-get remove --purge alsa-base
sudo apt-get remove --purge pulseaudio
sudo apt-get install alsa-base
sudo apt-get install pulseaudio
sudo alsa force-reload

When I start the computer and the login screen appears, I hear one sound - the sound Ubuntu usually makes when there's an error. After I log in, however, I can't hear anything again. The sound works perfectly on OSX - it's only Ubuntu that seems to be having this problem. Is there anything else I can try to get the sound to work?

  • time to move towards ubuntu 14.04 lts release. Have you tried that? – NKN Apr 25 '14 at 14:02
  • @NKN: I upgraded, but it didn't fix the sound... – LateCoder Jun 25 '14 at 22:33
  • @NKN: Never mind, it worked! – LateCoder Jun 25 '14 at 23:34
1

Have you checked to see if pulseaudio is actually using the correct sound card? I had a similar problem and solved it by reading the Arch Linux wiki

sometimes it thinks HDMI is the default sound card; to solve this problem, install pavucontrol and set Analog Stereo as the fallback device.

Alternatively you can do this via alsamixer and select the correct sound card via F6 (once you are inside alsamixer). If you have selected the correct sound card, a series of volume bars should appear, use the arrow keys to select "master" and adjust the volume with up and down arrow keys.

Hope that helps :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.