1

Suddenly the hibernation mode on my machine stopped working. \

Symptoms:
When I "hibernate" is still available in under "Shut down" but when I pushit - the pc screen gos off for a 2 seconds, then the pc is on again.

What I tried:

  • Tried to dis- / enable hibernation via powercfg -h off powercfg -h on
  • Tried to disable and reenable S3 in BIOS
  • disabled awaking via mouse and keyboard
  • checked powercfg -requests which is empty
  • killed every service, which is not from Microsoft

Any ideas?

Update:
I did a safeboot via msconfig - hibernate worked as charm. However when I switch to normal boot - hibernate still does not work

7
  • 1
    Storage space full? Hibernating requires as much free space as you have RAM.
    – Holloway
    Apr 24 '14 at 21:38
  • 1
    The first step. Boot into a minimal startup configuration. This will prevent any program that normally starts up that is preventing the computer going into hibernation. If it works update the question and we can go from there. If it does not no harm done.
    – Ramhound
    Apr 24 '14 at 21:41
  • I tried a safeboot and hibernate worked. But in normal boot it still doesnt work..
    – Skip
    Apr 25 '14 at 7:23
  • @Skip well do ctrl-shift-escape (that's task manager), and look at what processes are in normal boot but not in minimal. Try booting normally and closing unnecessary processes and try hibernating. troubleshooting like that. and by process of elimination you may find the suspect
    – barlop
    Apr 26 '14 at 21:05
  • 1
    @Skip did u terminate all processes such that in normal mode u have exactly the same processes as in minimal mode? I wonder if maybe a process is reading c:\hiberfil.sys u could try sysinternals process monitor n make a filter to look for that file.also process explorer-find...find handle..hiberfil.sys or hiberfil. see if process monitor and process explorer show anything. Also, btw, this may not help but process explorer if you hover over a system process like svchost.exe it can show u the services associated which is useful if u know the offending service or wanted an idea of one to test
    – barlop
    Apr 28 '14 at 1:07
0

My solution was to restore Windows from backup, which as I understand isn't a real solution

0

Try using this in "Run" (Ctrl+R) :

cmd /c shutdown /h & exit

Or you should use taskmgr to check whether some programs are running to prevent you from hibernating. If you still can't solve it, you may need to re-install your windows again.

Cleaning the power button may be a silly method, but you'd better try.

EDIT---

Reading your comments, you should try checking your SERVICE. Yes, service in taskmgr! Process may not show some of the background-process running.

0

I've fixed the hibernation issue on Windows 7 SP1 by applying KB2541014

Update for Windows 7 (KB2541014)

Hibernation does not work or memory dump file is not created after you install Windows 7 or Windows Server 2008 R2 Service Pack 1

Consider the following scenario:

  • You have a computer that is running Windows 7 or Windows Server 2008 R2.
  • You use a SCSI miniport driver as the device driver for either the memory dump file or the hibernation file on the computer.
  • You install one of the following updates:
    • Hotfix 2320550
    • Windows 7 and Windows Server 2008 R2 Service Pack 1 (SP1)

In this scenario, one of the following symptoms occurs:

  • When a fatal error causes a Stop condition, the operating system does not generate a memory dump file of the system memory.
  • When you try to hibernate the computer, the computer restarts instead of hibernates.

Cause: This issue occurs because the operating system cannot use the features that are required to create the memory dump file or the hibernation file on the SCSI miniport device.

Resolution: You can install the following update from Windows Update or from the Microsoft Download Center.

Source: Hibernation does not work or memory dump file is not created after you install Windows 7 or Windows Server 2008 R2 Service Pack 1

1
  • I have provided what I feel the required edits to improve your answer. Please take a look at it, and in the future, strive for better answers.
    – Ramhound
    Jan 17 '17 at 17:59
0

Try typing shutdown /h at the command prompt. If the hibernation fails, there will be a general message why it happened. It might give some more insight than we can guess here.

For example, it might say that some device drivers are blocking hibernation.

Or another example (probably not applicable for your case though): Some computers are unable to hibernate when the memory commit level is higher than the amount of RAM. Then they complain about insufficient system resources during hibernation. I do not know the strange reason how the "above-RAM-capacity-commit-level" causes hibernation to fail, but at least one can then close some programs to reduce commit level to less than amount of RAM.

0

I encountered similar problem on my computer with auto-restart after hibernation shutdown. Previously my computer was hibernating normally, and not automatically restarting.

I tried deleting some programs, that were displaying error message in event viewer under Administrative Services in Control Panel. I also set selective start-up under System Configuration from Control Panel.

This appears to have enabled hibernation to work normally, and not automatically restart the computer.

The next step would be to add the programs that load upon startup one by one until the offending program is found. A bit tedious, but should identify the program causing the restart from hibernation.

Hope this will assist in finding the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.