4

My Opera uses "Google.co.uk" instead of "Google.com" for searching. How can I change it to "Google.com" as default search engine? (with auto-suggest feature)

0
0

I managed to change it on Windows 7 this way:

Edit the default_partner_content.json file located at:

C:\Program Files (x86)\Opera\(Version)\resources\

Or if you installed it in another place, then the resources\ folder is the same place where Opera.exe is located.

For the UK, the thing you are looking for is this sequence:

  "gb": {
    "other": {
      "list": [
        "google_uk",
        "yahoo",
        "bing",
        "amazon",
        "wiki"
      ],
      "speed_dial_index_list": [0]
    }
  },

just change "google_uk" to "google_com" there.

Everyone else, just look for your country on that list and edit it. I also changed the Wikipedia search, to look for articles in English.

Or, you could redefine what "google_uk" means. Look for www.google.co.uk, and switch it to www.google.com.

Everyone else, just replace the domains you have, with the ones you want to have.

Save, then re-launch Opera, and enjoy.

6
  • Mine was in C:\Users(user)\AppData\Local\Programs\Opera(version)\resources
    – Shayan
    Feb 8 '19 at 11:13
  • Now I did this, and when I want to launch opera I get an error: At least one file with recources (.pak) is corrupted. Please reinstall opera.
    – Shayan
    Feb 8 '19 at 11:16
  • Modifying this file in any way will result in the error
    – Shayan
    Feb 8 '19 at 11:19
  • Opera has probably closed off their infrastructure even more. They've been losing transparency every year, which made me switch to Vivaldi. Feb 8 '19 at 11:40
  • Yeah well, I also tried this forums.opera.com/topic/2242/… and it didn't work, it suggested editing C:\Users(username)\AppData\Roaming\Opera Software\Opera Stable
    – Shayan
    Feb 8 '19 at 11:55
1

You can set a cookie so that your results are always global.

Just add NCR after the Google.com/ . this will set the cookie for global Google site. So next time the results will not be localized based on your country

http://google.com/ncr

1
  • 1
    That cookie is probably utilized by Google. But Opera is opening directly google.co.uk, so it's not working. Oct 17 '17 at 16:02
0

We are going to search for a file named Local State, it could be in a different location based on your installation (depending on where you installed the program).

Open up Opera, click on the O icon on top left sidebar, click on Help -> About Opera. On the opened window, under Browser Identification, you will see Paths. Copy and open the Profile Paths in Windows Explorer, and edit the Local State file with your favorite text editor:

Here's where I found mine:

C:\Users\user_name\AppData\Roaming\Opera Software\Opera Stable\Local State

Search for country and country_from_server and edit GB to US for both of them.

"location":{"country":"GB","country_from_server":"GB"}

Change it to:

"location":{"country":"US","country_from_server":"US"}

US will use google.com, but if you want to change it something else, here is a list with ISO country codes: https://docs.oracle.com/cd/E53547_01/opera_5_04_03_core_help/iso_and_country_codes_23428_1.htm

1
-1

Country is based on your default Opera language.

To change it, click on "Preferred Languages" button in Settings / Browser / Language, choose your preferred language.

Preferred Languages screenshot

Restart Opera and this should work as expected.

1
  • 1
    I don't think so. I have it configured to use U.S. English, but it's still opening google.co.uk. It's trying to detect your IP address and geo-locate it, so when you're using a VPN/proxy, it geo-locates it instead. Oct 17 '17 at 16:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.