1

Trying to run a Perl's script in Linux Ubuntu 11.10, but when Cd to the path, says : no such file or directory, but i can clearly handle the files inside the path.

when trying to change the permissions of the folder, does not allow me to do it, even though there are not more users in this computer.

when right click on the folder, on permissions, then in file access, selecting "read and write" does not work, cause returns to "___" option.

What to do in this case?

update update: hey, I think bash is doing really bad, I tried to only left the specific folder I was talking about, but when I Cd Desktop the bash is giving me the names that were there previously.

example, I only have folder called phonetizer. I go with the explorer inside the folder "phonetizer" and I copy the path from menu "go" which is this one:

/home/one/Desktop/ Phonetizer

Then i go to the terminal: type

cd /home/one/Desktop/ Phonetizer

and returns this.

one@one-desktop:~/Desktop$ 

also when i ls on Desktop in the terminal i got this:

one@one-desktop:~/Desktop$ ls
1.pl~             foo.txt~          Phonetizer                wildmarks.pl~
bar.txt~          input-text.txt~  sorting en ultraedit.txt~
equivalents.txt~  output.txt~      Untitled Document 1~

I don't know why is giving me those old names, since i moved them to other folder.

  • All of those filenames end with a ~. This usually indicates that they are backup files created by an editor like vim. – user2313067 Apr 26 '14 at 8:15
0

There appears to be a space before Phonetizer in the name.

Try

cd /home/one/Desktop/\ Phonetizer

or

cd "/home/one/Desktop/ Phonetizer"
| improve this answer | |
  • that worked, thanks, unfortunately my script has some issues, but that would be another question. thanks for the fast answer. – arturo_bengala Apr 26 '14 at 7:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.