1

I am running Centos 6.4 and Eclipse Juno and I like coding at 8pt size. I keep seeing a few letters with no spaces in between them. I have tried DejaVu Sans Mono Book, Droid Sans Mono etc. The font in screenshot is DejaVu Sans Mono Book at 8pt in Eclipse and QtCreator. I have set the font rendering to default "Subpixel LCD smoothing", Hinting is at Full, Subpixel order is RGB and smoothing is Subpixel(LCD). I have tried other settings i.e. "Best Contrast" and "Best Shapes" but that removes the crispness of the font. Notice the same font looks better in Qt than Eclipse. Is there some flag/setting that I need to set to make Eclipse font rendering better at small font sizes or is there some system-wide setting I am missing?

Here's a screenshot: Eclipse 8pt

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.