I want to change my laptop's power plan via Remote Desktop Connection, but the option is greyed.

I am logged with the admin account and both PC's are running Windows 7.

What could be the problem?


This should be possible if you connect to console via RDP. To do this, open command prompt and connect to RDP server like this:

mstsc /v:server /console

Replace server with your server's hostname or IP.

Console is special kind of remote session to which only one connection can be connected at the time. You can find more information on Microsoft TechNet: http://technet.microsoft.com/en-us/library/cc740144%28v=WS.10%29.aspx

| improve this answer | |

You must be in a local session with the computer to change power options using the battery icon (I don't know why unfortunately).

You could possibly use the Control Panel for this, but again I think you must be in a local session.

You could change by a VNC connection, as that will connect you to the console.


| improve this answer | |

For some reason Microsoft thinks it's a good idea to disable certain functions when connected to Remote Desktop. You could install Teamviewer (over Remote Desktop) and give it another try.

| improve this answer | |
  • Teamviewer is a screen sharing software, not a remote control software. Think Remote Assistance. – kinokijuf Apr 27 '14 at 11:29
  • So what? He is talking about his own laptop, so this is not about maintaining hundreds of laptops, and in this situation I don't see the difference. – SPRBRN Apr 28 '14 at 7:27
  • The difference is that other people will be able to see what he does – kinokijuf Apr 28 '14 at 11:06

Typically, you can do from a command line, in a remote session, what you can't do through the UI. In this case, you should be able to run POWERCFG with appropriate options, even though you can't run through the battery or control panel UIs.

The options for the command are detailed at http://technet.microsoft.com/en-us/magazine/ff700230.aspx

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.