1

No matter what I try, I can't seem to get my computer to boot from USB. I would very much appreciate any help. I'm usually quite good at these things but the solution here eludes me. I have been working with 2 separate computers (in case the problem was just with one):

  • Desktop: Windows 7 pro x64, AMD Phenom II 945, Gigabyte GA-MA790FXT-UD5P, supports USB2.0
  • Laptop: Windows 7 home x64, Emachines E627 (Athalon 64 TF-20, ? MB, but supports USB2.0

I've got a 16GB USB stick and I've tried this with others as well (in case it was a hardware problem with the USB).

I've tried installing various bootable USB images using various boot USB creator tools.

The tools that I have tried include:

  • Xboot
  • YUMI
  • Universal USB Installer (I can't post more than 2 links)
  • and probably a few other I'm forgetting right now.

With those, in turn, I've installed the following list of solutions (in order) on the USB thumb drive:

  • A multiboot USB containing a variety of bootable tools such as AV rescue disk, Hiren's BootCD, Trinity Rescue Kit, Kali linux, Ophcrack, etc, etc
  • Only Hiren's BootCD
  • Only BitDefender's Rescue CD (as this one matches my currently installed av)

In every case (3 solutions * 3 boot usb installers * 2 computers) the computer happily boots into windows as if it doesn't even notice that I'm trying to boot to USB. This is maddening.

Random other little things I've tried include:

  • Legacy USB is enabled
  • Manually choosing each of: USB-HDD, USB-FDD, USB-CDROM, USB-ZIP from the boot menu
  • The only other boot options available are HDD, CD-ROM, LS120, FLOPPY (conspicuously missing is anything about a removable drive)
  • Completely disabling HDD from the BIOS boot
  • Disabling hardware virtualization in BIOS
  • Screwing around with other bios settings..
  • syslinux vs grub4dos
  • I'll add others as I think of them..

So ya, if anyone can help, that would be amazing. Thanks.


As per the suggestion in the comments, I've also tried plop linux. I followed this step-by-step procedure, however my computer still booted to windows.

  • Have you tried using a Plop Linux boot CD? This boots from CD and loads a minimal Linux bootloader to memory, that allows booting from USB. It's useful for machines that aren't able to boot from USB sticks (like older laptops, unlike yours). The site is plop.at/en/ploplinux/usb.html – jdh Apr 28 '14 at 3:25
  • The options you said you manually chose from the boot menu aren't for USB sticks. You probably want "removable media" or something similar. – Nattgew Apr 28 '14 at 17:12
  • You write "various bootable USB images using various boot USB creator tools." that is unnecessary. Just test with one bootable image. Take a bootable USB stick doesn't matter what is on it. Test if it boots from another computer. If so, the image is fine for your test. I once had a situation where a computer needed a lower capacity usb stick.And don't necessarily look so much at the main BIOS screen.Press the key for the BIOS boot menu, that can sometimes give an option to boot USB. And also, the model of laptop or mbrd, in case others have had an issue with it. – barlop Apr 29 '14 at 0:20
  • And u could disconnect the hdd(may speed things up for when it fails to boot from usb), so you won't have to wait for the OS to load from the HDD. – barlop Apr 29 '14 at 0:23
  • @jdh Thanks for the suggestion. I just finished trying ploplinux but it still booted to windows as if it wasn't even there. I also tried several times using different bios settings. I'm about to update my answer with the results. – Inversus Apr 29 '14 at 7:40
0

Three suggestions:

  1. Check your BIOS boot settings one more time. If you've "completely disabl[ed] HDD from the BIOS boot", but "in every case...the computer happily boots into windows", something very odd is going on. Simplify your troubleshooting by insuring that if the machine will not boot from USB, it won't boot at all.
  2. Make sure your USB device/drivers are configured for SERVICE_BOOT_START (0x00000000) and USB Selective Suspend is disabled in each machine's active power configuration. Verify this via the registry. Selective Suspend will sometimes reassert itself in Windows 7 based on device supported wake states rather than user power settings.
  3. Disable Legacy USB support for this device (not Legacy Boot / CSM support in your UEFI setup as per mihi--keep that enabled) as that can prevent drivers from entering the D0 state until called by the OS file system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.