1

I want to implement a daily reporting system for myself and work colleges. I was thinking of using MS Word to do this by creating a master document and sub documents. I create a master document with peoples names in level one, then the days of the week in level two.

This works fine and when I edit a sub document I see the text update in the master document. However, when I close the master document (after saving it) when I re open it the text is gone and has been replaced with a hyper-link to the respective sub-documents :- this is not what I want.

So: How do I stop word hyper-linking the sub-documents and instead make it display the text contained within them (I thought this was the whole point of having a master doc???!!!!)

2

That is how Master Documents work.

A master document contains links to a set of related subdocuments. Use a master document to organize and maintain a long document by dividing it into smaller, more manageable subdocuments.

(my emphasis added)

It provides a way to combine and organize numerous documents into one large document. When you want yo view the linked document, you click the link.

I think you may be looking to link to other files, not necessarily use Master Document.

  • Hi Charlie, thanks for your answer. I see now that this is the intended operation. However, when the master document is open for the first time I do see the text appear. Is there a control in word to toggle this behaviour? – Tim Mottram Apr 28 '14 at 13:08
  • Thanks for all your help, the new method works perfectly. One question, to update to the latest version of a file I have to use f9. Is there a way to automate the update every time the file is opened? – Tim Mottram Apr 28 '14 at 13:25
  • You've not said what version you are using, so it's difficult to say what will control that behavior. I do know in 2010, you can choose to update links on open from File>Options>Advance>General. – CharlieRB Apr 28 '14 at 14:12
  • If this answers your question, please choose the check-mark to the left. – CharlieRB Apr 28 '14 at 14:13
  • Sorry, I am using Version 2007. I'll have a look for that option. Thanks for your time. – Tim Mottram Apr 28 '14 at 14:40
2

For the sake of anyone else who has just spent 20 minutes creating a Master Document with embedded text (as you might for a book) but now just sees hyperlinks:

  1. With the 'Master Document' open,
  2. Switch to Outline view.
  3. Look for 'Expand Subdocuments' button and click that.

Your text should return to being 'embedded' as it was when you closed the Master Document.

That's it: utterly trivial, but buried in the outline menu and not remotely obvious why MS 'thinks' you'd want to suddenly change the view to hyperlinks when reopening the document. LaTeX vastly superior for this but, alas, not always an option when co-authoring.

These instructions should work for Word versions available under Office 365 or similar.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.