20

I'm using the most recent version of Google Chrome (34.0.1847.131 at the time of writing) on OS X 10.8.5, and for a few months I've been having intermittent issues resizing browser windows. There doesn't seem to be any pattern as to why this issue occurs sometimes but not other times.

I'll move my cursor over the right side of the window, then click and drag the window to a smaller size. However, when I let go of the mouse button (or in this case the trackpad) and move the cursor, Chrome continues to resize the window as I move. When this happens, I am unable to click on anything in any of Chrome's windows, and if I switch focus to another program, I am unable to bring Chrome back into focus (unless I minimize all other windows that are in the way.) The only way to stop it from resizing is to Force Quit Chrome entirely, and go back into it.

I've attempted to find a solution to this problem on various message boards and support forums, but I can't seem to find anyone else that's even had the same problem, nevermind someone who has found a solution.

I'm not sure if this helps, but I am using a Mac Mini with two screens, alongside an Apple Wireless Keyboard and Trackpad.

Has anyone had this issue in the past? If so, what steps were taken to correct the issue on a forward basis? If you have not had this issue in the past, what would be some steps that I could take to debug the cause of the issue?

5
  • Were you able to solve this? I'm having the exact same issue and it's driving me nuts!
    – morbaq
    Sep 5, 2014 at 10:49
  • @morbaq Unfortunately not, no. While it doesn't seem to happen as often as it did when I originally posted the question, I can confirm that it still happens from time to time in version 37.0.2062.120
    – Marc
    Sep 16, 2014 at 15:28
  • Also happening to me on 10.8.5, Chrome 39.0.2171.36 beta (64-bit) (and previous Chrome versions as well)! It seems to trigger sometimes when I forget to release a modifier key before using a window-resizing gesture with BetterTouchTool, so it might have something to do with how Chrome handles the mouse-up event to get out of window-resize mode (i.e. it never calls the code that exits the mode). But I'm also stumped and tired of force-quitting :(
    – btown
    Oct 27, 2014 at 23:12
  • I am using two monitors too, one attached to my laptop. The issue started after I moved my chrome window from a different desktop (where it was inaccessible to me) to the "main" one, and X'd out the Desktop 2. Then I set the background image on second monitor because it had gone away. Then the sticking problem happened. I tried unplugging & replugging in my dual monitor (where it was sticking). It was not sticking to the left on my regular laptop screen. That fixed it for me! :)
    – Rock Lee
    May 13, 2019 at 6:25
  • FWIW, this still happens and just happened to me. Chrome 84.0.4147 on MacOS 10.15.6 running on a 15" MacBook Pro. I've never used multiple displays on this laptop. Jul 24, 2020 at 19:12

2 Answers 2

1

When searching through the issues backlog I don't see anything that fits your versions and description. I do see dozens of resize issues on that Chrome build.

While it's no grand conclusion, I would troubleshoot by running AppCleaner on Chrome then reinstalling to make sure all libraries are updated. Let me know how it works!

1

If this is still happening can you advise current versions in play? Sounds to me like a sticky trackpad/mouse setting (aka its not registering or not properly ) the release of trackpad/mouse as if you were still attempting to resize to say a 4k external or spanning displays..

1
  • It doesn't seem to occur anymore -- at least, I haven't noticed it -- on OS X Yosemite (Chrome 43.0.2357.134). At this point, it's hard to know whether the issue was with Chrome, the OS, or both.
    – Marc
    Jul 15, 2015 at 18:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.