I'm regularly getting ERR_NETWORK_CHANGED errors in Chrome. It's usually when using Google, or other Google products (YouTube, Drive, etc.), but has also happen on other various sites, but less often than it appears to happen with Google's sites.

After a few refreshes, the request goes through just fine.

I have not experienced similar issues in other browsers (Firefox, IE.)

The biggest frustration is that I'm having trouble even debugging/understanding the problem. What does "Network changed" even mean? Can someone lead me in the right direction about where to even start? Could it be a problem related to IPv6? Network drivers?

As far as I know, nothing about my network connection changed prior to this becoming a problem. I've tried restarting Chrome, updating Chrome, and restarting computer, and the error continues to come up.

I'm running Windows 8.1, Chrome 34.0.1847.131 (in Desktop mode), which is currently the latest version of Chrome.

Here's a screenshot, in case this is helpful:

enter image description here

  • I got it while Windows 10 was switching from WiFi to cable network. Nov 10, 2015 at 18:13
  • 1
    The solution for me was to unplug an iPhone 8 from my Macbook Pro, it was intermittently connecting and disconnecting (probably a bad USB cable) which, for some reason, was causing the ERR_NETWORK_CHANGED errors in Chrome.
    – disperse
    Jun 10, 2020 at 21:20
  • s Querstion: What does this mean Answer 1, 2, 3, 4, 5, the whole lot: Here's how to fix the problem! 🤦‍♂️
    – Phil
    Feb 18 at 6:59

11 Answers 11


What worked for me (though I am not sure why) was to disable IPv6.

I saw this issue with Chromium, Slack and Discord on Arch Linux. Poking around on the net made me check my network settings. I ran watch -n 2 'ip address' and saw inet6 flapping between link tentative and link noprefixroute. This made me wonder if some IPv6 configuration on my network was to blame, since mtr attempts would result in no route to host after a few seconds.

Sure enough, the following commands completely resolved the ERR_NETWORK_CHANGED issues, and various HTTP requests frequently failing in chrome, slack and discord.

sysctl -w net.ipv6.conf.all.disable_ipv6=1
sysctl -w net.ipv6.conf.default.disable_ipv6=1

If someone were to know why this worked, and what I should be checking into to actually solve this problem, I'd be grateful. I hadn't updated my Internet gateway or system in a long time before this issue began occurring. Maybe my ISP is to blame?

  • 2
    This fixed things for me on Ubuntu 18.04. I followed these instructions to disable ipv6: askubuntu.com/a/484487
    – JDiMatteo
    May 11, 2018 at 19:16
  • 1
    My problem was created from having ipv6 and docker containers, while the error happened frequently on chrome. I disabled ipv6 and chrome stopped throwing these errors. Oct 31, 2019 at 15:42
  • 2
    This worked for me as well on Ubuntu 20:04. THANK YOU! Feb 1, 2021 at 7:12
  • Worked for me in Mac. I used this link to disable ipv6: vladtalks.tech/vpn/how-to-disable-ipv6-on-mac
    – Aniruddha
    Nov 21, 2021 at 16:42

I stumbled upon this problem earlier today and learned that, for my situation, it had to do with the VPN software I was using on my Windows 8.1 laptop. Hopefully these potential solutions will help resolve the problem/point in the right direction for you or anyone else:

(it is important to note that these steps rely on your connection to the Internet working; ensure your access point/router is connected to the Internet by checking its status [blinking lights/directly connecting to the connectivity device and viewing its status page])

  1. First we need to verify that our interfaces can function. If you have WiFi in addition to Ethernet, check both connections by opening Network and Sharing Center.

    • If one works:
      • Disable the working adapter
      • Enable the malfunctioning adapter
      • Ping the loopback address by opening command prompt:
        • Windows Key + X
        • select Command Prompt
        • Enter: ping
    • If you get replies from pinging the loopback address, you know that the malfunctioning interface is now functioning properly with layer three connectivity, therefore, if you wish, you can proceed to checking the settings of the working adapter and cross-referencing them with the misconfigured adapter to accurately diagnose and resolve the issue.
      • Microsoft can do this for you automatically if you click here!
  2. When I viewed the properties of my interfaces in Network and Sharing Center, I realized the DNS settings I manually configured had been reconfigured from VPN software I had installed recently. I tried manually changing the DNS servers back for these adapters, but it hadn't resolved the problem. Upon inspection, I saw the TAP-WindowsAdapter that had been added to my system; my suspicion is the way that the third-party software had configured my network adapters to function together, which led me to this problem! I would like to know how the process of this software works, but for now I'm left feeling that DNS configuration was the source of the problem. I came to the conclusion that uninstalling this software may resolve the problem, and thus I came to my resolution. After re-installing this software I haven't run into this issue.

  3. I read here, that the problem could be caused by privacy extensions for IPv6, which would disallow you to change your global IPv6 address. You can check the thread there for how to configure those settings and see if that resolves your issues.

  • when i read point 1 i turned off my wifi switch on the laptop and lo and behold suddenly all ok (@John MacIntyre's also would have been helpful if i'd read that first) Jan 31, 2018 at 17:08

For me the problem was the docker daemon! Once I stopped with:

sudo service docker stop

and stopped some containers I had running (likely bound to the local network with --net=host), when the docker daemon automatically restarted, I restarted again (which I have to do to switch to the nvidia runtime for some reason) -- the net::ERR_NETWORK_CHANGED errors in Chrome console went away.


I had a similar issue where every few page loads, I would get this error message. When I went into Network Connections to see if anything seemed amiss, I noticed that my "Hamachi" and "vEthernet (LogMeIn Hamachi Virtual Ethernet Adapter Virtual Switch)" virtual network adapters kept disabling / enabling themselves. I'm assuming this was happening because I have other virtual network drivers installed (Hyper-V and Virtual Box).

To fix it, I just disabled the two adapters and this stopped the "Network changed" message from coming up.


I was getting the ERR_NETWORK_CHANGED error this morning. Actually, Chrome wouldn't work and neither would Slack. However I could ping Google and even load every website I tried in Internet explorer.

Finally, I looked at my network adapters thinking something was misconfigured and saw the X on my Local Area Connection kept flickering on and off.

I pushed my Ethernet connection in tight and bam. Fixed.

It looks like my connection kept flipping back & forth between ethernet & wifi, hence the ERR_NETWORK_CHANGED error. Apparently Chrome is sensitive to this for some reason where as IE seams a little more robust in this area. Seems obvious why Slack was showing an error since they probably open a connection and keep it open.

  • 1
    Thanks. I had the same problem, except my WiFi adaptor is the one that was flickering on and off.
    – Sam
    May 21, 2017 at 22:13
  • This was basically the issue for me- wired connection wasn't solid, so windows kept trying to turn fallback wifi connection on and off. i turned off wifi, disconnected wired cable, then reconnected it and it is working fine now
    – Kip
    Feb 6, 2019 at 14:18

The problem started for me after upgrading to Windows 10 on my laptop with wifi card "Intel Wireless-N 7265" (driver v. Chrome is version 53.0.

This site can't be reached

Your connection was interrupted

Possible Solutions

Here are some approaches to solve the problem that I found researching the entire day:

  1. Deactivate all network adapters but leave the one you use enabled.
  2. Open the CMD and enter ipconfig /flushdns to clear all cached DNS settings.
  3. Clear the entire cache of Chrome.
  4. Of course, update your network card driver (or downgrade if the latest one causes problems).
  5. Uninstall your network driver and let Windows reinstall it.
  6. Try to assign the DNS server addresses yourself, see settings under Internet Protocol v4 of your network card.
  7. Try to reset TCP/IP if you have Internet connection issues, see Microsoft instructions.
  8. Try disabling the Bluetooth adapter.

Wireless Card settings. Go to your Device Manager, open the properties of your wifi card and:

  1. go to the tab Power Management. De-select "Allow the computer to turn off this device to save power".
  2. go to tab "Advanced" and select under "Wireless Mode" instead of 802.11a/b/g the slower one 802.11b. Source. Check all available settings on this Intel page.
  3. go to tab "Advanced" and choose "disabled" under "U-APSD support". Also try to set "Transmit Power" to Medium, than to Highest again to have Power Save Polling (PSP) deactivated.
  4. go to tab "Advanced" and choose "disabled" for "Packet Coalescing".

  5. Try to change many more options in the wireless adapter settings according this intel post. E.g. HT Mode disabled, 802.11n Channel Width at 20 MHz Only, Roaming Aggressiveness to lowest. However, as a user stated "None of this works."

  6. Go to Power Options, Wireless Adapter Settings, and choose "Maximum Performance".

The usual stuff:

  1. Update Chrome to the latest version, do all Windows Updates.
  2. Remove your latest installed Chrome extensions.
  3. Check your router. Try to find log files to nail down the issue.

Please comment, which solution worked for you.

Good luck!


I ended up buying an Wireless USB adapter of TP-Link (Model TL-WN823N, about 10 USD) that seems to work without any issues. What a pity that Intel is incapable to make their drivers work with WIN 10.

  • 1. worked for me! The offender seems to be TeamViewer VPN Oct 23, 2018 at 20:10
  • how do i install ipconfig on ubuntu?
    – chovy
    Oct 24, 2019 at 17:44

If it happens that you have connected and iPhone device to your computer try unplugging it. This helped in my use case.

  • I saw the same problem, unfortunately I need to have plugged in because of debugging ;/
    – Darex1991
    May 25, 2022 at 7:07

You can search in Console.app for more information.

I can see a line as follows so nearby you can maybe find what is causing it.

default 18:48:40.255436+0200    opendirectoryd  Processing a network change notification

For me it was my iPhone connecting and disconnecting rapidly. Bad cable or charging port.


I managed to reduce this problem by disabling my extensions, unplugging my account Google Chrome and clearing browsing data from the beginning. (Clearing everything except the automatic filling) After it rebooted the computer!


What worked for me was updating Homebrew and all of my formulas.

brew update
brew upgrade

I wasn't able to track down which formula initially caused the issue. After upgrading everything, the ERR_NETWORK_CHANGED problem went away.


Similarly to another answer here, I used watch -n 1 ip address to find out I had an OpenVPN tunnel for a pet-project trying to start every few seconds, but it was to a revoked domain so it failed, but that still caused a brief creation of a network interface (tun0 in my case) that lived for less than a second. So Chromium has been detecting that network interface creation and treating it as an actual network change, even though it didn't need to use that interface.

  • what did you use in place of ip address? pinging something on the internet?
    – Reese
    Dec 3, 2022 at 1:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.