5

I installed Solaris 11 X86. I installed solaris-desktop.

Then Solaris boots to GUI mode.

How can I make the Solaris boots to console mode? (And then optionally starts X by hand?)

6

You can disable booting into the GUI by running the following command:

svcadm disable application/graphical-login/gdm:default 

This will disable the GUI until you re enable the service.

1
  • 3
    After disabling the gdm service, you can start X by hand via the startx command (to run as the user who runs startx), or by temporarily re-enabling the gdm service to offer a login screen to choose which user to run X as. – alanc Apr 30 '14 at 19:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.