3

I am using pass (http://www.zx2c4.com/projects/password-store/) on ubuntu 12.04.

Process:

apt-get install pass
gpg --gen-key
pass init <generated gpg id>
pass insert test
pass test

After the last command, this is the output:

gpg: gpg-agent is not available in this session
gpg: can't query passphrase in batch mode
gpg: Invalid passphrase; please try again ...
gpg: can't query passphrase in batch mode
gpg: Invalid passphrase; please try again ...
gpg: can't query passphrase in batch mode
gpg: decryption failed: secret key not available

I have searched all over and have yet to find an answer as to why it won't prompt me for a password? I have tested this on three ubuntu 12.04 machines (all with the same error), but when I tested it on mac os 10.9 it prompts me for a passphrase. (This is why I assume the problem is that it isn't prompting for a passphrase).

Any ideas?

migrated from serverfault.com Apr 30 '14 at 13:21

This question came from our site for system and network administrators.

  • FWIW n a later version of Ubuntu I followed your instructions and it worked. – user35787 Apr 30 '14 at 7:45
  • Are you aware of ubuntuforums.org/showthread.php?t=2136182 ? It looks exactly like your issue and suggests setting GPG="gpg2" in /usr/bin/pass – syneticon-dj Apr 30 '14 at 7:57
0

syneticon-dj takes the cake! Appending '2' to GPG="gpg2" in /usr/bin/pass is a solution.

Thanks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.