I have a Dell XPS 8500 with I7-3770 CPU and 8 logical processors, 24Gb RAM.

It's running Windows 8.1 (Update 1). Recently I've noticed the System process is using 12.5% (1/8) of CPU on a constant basis.

Using Process Explorer - Sysinternals, I've identified a single thread in the system kernel that is consuming this amount of CPU. This thread has starting address: ntoskrnl.exe!RtlSidHashLookup+0x1ffc.

What is this thread, and what can I do to stop it from constantly using 1/8 of my CPU?


3 Answers 3


Thanks to tumchaaditya for suggesting sfc /scannow. It identified a corrupted printer driver and associated .inf file: CNBJ2530.DPB and prncacla.inf.

That led me to the solution: http://www.sysnative.com/forums/windows-update/7702-guide-cnbj2530-dpb-and-prncacla-inf-corruptions-windows-8-8-1-a.html

This page contains detailed instructions on how to fix what is apparently becoming a rampant problem with windows 8/8.1. Running "DISM.exe /Online /Cleanup-image /Restorehealth" replaced these bad files with new versions downloaded from MS Servers. Rerunning "sfc /scannow" confirmed everything was healthy again.

Following a reboot, the NT kernel is now using 0.13% of CPU instead of 13%.

  • 6
    this worked for me with the exception that I didn't download and install the exe in that link. A bit of an aside but I'd be very wary of using anything like that - you have no idea what you're putting on your machine
    – JonnyRaa
    Jun 11, 2014 at 12:36
  • This worked for me also (and also without downloading the link.) I would mention that the reboot part is important. Even after running the cleanup with DISM, the kernel CPU hogging was still happening when idling. However, it went away after a reboot and has not returned.
    – reirab
    Feb 21, 2019 at 23:17

In my case it was a different problem, but same symptoms. It was the RunFullMemoryDiagnostic task that somehow never ended. Just disable it in the Task Scheduler, inside Microsoft > Windows > MemoryDiagnostic > RunFullMemoryDiagnostic.


Initially I had the System Idle Process constantly at ~25% CPU. I ran (in the console as admin) "sfc /verifyonly" & "sfc /scannow" - both showed no OS or system integrity errors/problems. So I killed the System Idle Process (in Task Manager) & rebooted, then I saw the System process at ~25% CPU (System Idle Process had disappeared). Waited a couple of days (rebooted 2-3 times) hoping it would resolve on its own, did not. Then rebooted in diagnostic mode (press F2 quickly just as it starts booting up), did not run any diagnostic, just looked around, then hit Esc to exit & let it complete its bootup process. The 25% CPU problem was solved, there was no System Idle Process & the System process was at 0.4% CPU. All is back to normal, no idea why this worked !


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .