3

I've encountered following problem while using Opera web browser:

When I click on a magnet link on some web page like

magnet:?xt=urn:tree:tiger:CXW6MJFRNOEFU2STCBWWOIYZLVCR2FTR37SQCXY&xl=352342016&dn=ER%20-%207x16%20-%20Witch%20Hunt.avi 

Opera is asking me if I want to open that link with my DC++ client.

If I click 'Yes' button then my DC++ client is correctly "opening" the clicked magnet link and performing some action on it. There is also an option "Do not show this dialog again" in Opera's dialog, but it doesn't seem to be working correctly. If I check that option before answering 'Yes' and then click on other magnet link of the same kind the Opera will again ask me about how to open new link.

I haven't found protocol association in 'Control Panel > Default Programs > Set Associations' part of my Windows Vista settings, but if I paste magnet link in "Run" dialog then Vista will handle that link perfectly.

I've tried to find out how to manually set protocol association in Opera and found 'Programs' page of browser's advanced settings. There I discovered that instead of storing protocol to application associations Opera tries to store per-link associations (There are several entries with exact links as they was on web page as value of protocol field). If I click on the links which are already stored in Opera's protocols associations browser will ask me about them again.

I haven't found any information on how to resolve this problem on the internet, maybe someone on this site will be able to help me.

4
+75

Have you tried setting the association manually?

Go back to the Programs section of the Advanced settings, delete the existing magnet protocols and add a new one. I'm using uTorrent, so I have this entry:

Protocol: magnet
Program: "C:\Program Files (x86)\uTorrent\uTorrent.exe" "%1"

  • I would say the same thing: reassoc the protocol. So, one vote up. xD – igorsantos07 Dec 13 '09 at 2:02
  • No, what isn't helping. The opera says "No application is registered for this protocol" each time I click a magnet link, if association is manually set. – okutane Dec 13 '09 at 7:37
1

Opera ignores windows file associations.

You must go in Tools>Preferences>Advanced>Programs then Include Protocol: "magnet" without quotes Open with anoter program: select your DC++ client

  • This is already suggested by efotinis and tested by me and isn't helping. – okutane Dec 17 '09 at 11:17
1

Try to use x86 version of DC++ client. Run DC++ client "As Administrator" once to register magnet protocol. Then start Opera.

0

I have noticed that this happens with files also, but only of specific file types - exe, zip, rar etc. For pdf, if I check the "Don't ask me again" box (to open with SumatraPDF), it doesn't ask me again. Maybe it is a security feature?

  • I don't know, since I'm still searching for answer. I think there should be the way to workaround this even if there are any security reasons to not let me give an answer once and for all. – okutane Dec 10 '09 at 14:24

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.