Because the Windows Update was not offering this as update after several update checks, I went online and downloaded the Microsoft Camera Codec Pack (6.3.9721.0) from the download center. I used the 64-bit installer MicrosoftCameraCodecPack-x64.msi to install it on Windows 7 SP1 64-bit and rebooted. Back in Windows Explorer, my CR2 files are still not getting any thumbnail previews.


I chose to do a repair install through the Control Panel. Repaired, requested reboot, grated, rebooted, logged in, the problem remains. I'm not sure where to go from here. Just to make sure that this was not only related to thumbnails, I tried opening one of the files with Windows Photo Viewer. It didn't work.


Windows Photo Viewer can't open this picture because [bla, bla, bla]

Here's what Microsoft has to say.

Version: 9721.0 [it's in fact 6.3.9723.0 according to control center]

Date Published: 4/22/2014

The Microsoft Camera Codec Pack enables the viewing of a variety of device-specific file formats in Window Live Photo Gallery as well as other software that is based in Windows Imaging Codecs (WIC).

Installing this package will allow supported RAW camera files to be viewable in Windows Explorer.

Supported Operating System

Windows 7, Windows Vista Service Pack 2

The Microsoft Camera Codec Pack requires the following:

Processor: Intel Pentium 4 processor equivalent or higher (1.6 GHz or higher, with SSE 2 extensions or compatible) Memory: 1 GB of RAM or higher Resolution Minimum: 1024 × 576

I have Windows 7 with SP1 integrated. Could this be the problem? It only says "Windows 7". I know it sounds sick, but could it be that Windows 7 is not supported if SP1 is installed? I will try uninstalling and reinstalling back and forth a few times, get the latest updates from Windows Update installed. But beyond that, I'm pretty much lost.

Where do I even begin to troubleshoot this problem, on a low level? Like, where are these "plugins" installed in Windows? And what "bit" version is Windows Explorer in 64-bit Windows? Is it a 32-bit program or a native 64-bit program? I fear that this could be a "bit" compatibility issue, like so many times before with Windows and Microsoft. I know this has worked with Windows Vista 64-bit, I have used it. But then it might have been a different version of the plugin.


Yes, as evident by the file type icons, I do have a program that can open these files for me. I have both Photoshop and Photoshop Lightroom. I just feel like it would be useful to have a small preview of these files in Windows Explorer when I work with them. I don't see the point in bringing out the heavy artillery like Photoshop just to have peek at what photo that file holds, and I don't necessarily want to import all of these files into Lightroom. I think it's a normal, legitimate request, it's just too bad Microsoft can't deliver plugins for proprietary file formats except their own.

Canon does have a Windows plugin for their CR2 files, but it's been last updated 4 years ago, in 2010. It's as old as the first release of Windows 7. And it's interesting that it comes with one particular limitation.


• 64-bit Operating systems are not supported

• Before installing Canon RAW Codec, install an application that supports Windows Imaging Component.

So here they say all of a sudden I must have Window Live Photo Gallery in order to use this Canon plugin. That completely contradicts what Microsoft says. I read that as if it's an option, not a requirement (or it would have said so in the system requirements). I take it that both Window Live Photo Gallery and Windows Explorer use WIC. No?..

The Canon folks even go as far as saying that Window Live Photo Gallery is a requirement!


Canon RAW Codec is a software plug-in that enables the import and display of Canon RAW image files when installed in Windows 7* / Vista (SP1/SP2) / Windows XP SP2 and Windows XP SP3. Windows Imaging Component (WIC) supported applications (Microsoft Windows Live Photo Gallery etc.) are required.

I tried to get a 32-bit instance of explorer.exe running but without any luck.

I used C:\Windows\SysWOW64\explorer.exe /separate as instructed by KB895561. All it does is start a separate 64-bit process under svchost.exe. The main explorer.exe process is still 64-bit on 64-bit Windows 7.

I also installed all the latest updates available on Windows Update, rebooted, but it didn't help. I installed the x86 version of the MS codec pack, rebooted, nothing. Uninstalled x86 version, rebooted, installed x64 version again, rebooted, installed x86 version over that, rebooted, still nothing.

Update 2 - Solution?!

On top of x86 and x64 versions of the damned MS codec pack, I downloaded and installed the Canon RAW codec plugin 1.8 and it worked. Despite the stupid warning messages about 64-bit on the site. My CR2 files got previews, and opening the files in Windows Photo Viewer worked too!!

Then I uninstalled Canon RAW codec, and it still worked! Only x86 and x64 versions of the MS plugin were still installed. So it takes a Canon plugin to kick the Microsoft plugin in the groin before it starts working? It should really say "system requirements: groin attach by a Canon plugin is required".

I then uninstalled the MS codec pack plugin, just to see if it would work without it. No it didn't. Only files that were open previously had kept their thumbnail previews, but when you open it in Windows Photo Viewer it can't read it.

Then I installed the x64 version of the MS codec pack plugin again and it works now. (Only have to figure out now how to get rid of the stuck thumbnail previews of the files that were previously open.) So now when I install the damned MS plugin, it actually works? What did the Canon plugin do that was so magical that it even made the MS plugin follow along?

  • For me this didn't work, so I've cleaned up registry entries (delete everything connected to file type and extension CR2) and then I've reinstalled MS codec pack. Of course every registry is different, so make copy before trying that and don't delete entries you aren't sure of.
    – Krzysiu
    Dec 1, 2018 at 13:08

1 Answer 1


I had the same problem with my Olympus .ORF files. I soon discovered though, that newly added files do display thumbnails. So I tried cutting my raw files from their original folder, pasting them in a temporary folder, and then cutting and pasting them back to their original folder worked. Tedious, but a work around.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .