3

UPDATE JUNE 4, 2015:-

My ISP provides a Wi-Max (wireless) device which receives the signals and sends it through LAN cable to my laptop. I've been using this device since last 5 years. Today, for a certain reason, my ISP's custom care center replaced the device with a new device. Now, I'm no more facing this issue. So, I think that the problem is in the modem, not in Windows 8.1. I hope that my update will help others.


I'm facing a problem where when I visit a site Google Chrome says to me:-

"This web page is not available"

This happens for many sites. I've searched on Google and have found a fix. If I run the following command of flushing dns caching

ipconfig /flushdns

then I can load the site. But after few seconds or minutes Google Chrome again gives the same (error?) message. "This web page is not available". I need to run the command again and again and it has now become very irritating. Anyone knows the solution of my problem?

OS: Windows 8.1 Browser: Google Chrome (Version 34.0.1847.131 m)

4

If it is the DNS caching on your system, try stopping and restarting the DNS client service in windows.

You can do this by running the following commands:

net stop dnscache
net start dnscache

Then confirm the cache is clear with:

ipconfig /displaydns

Plan B:

Close and reload Chrome. Confirm chrome is closed by checking in the task manager. (many extensions and plugins like to keep Chrome open in the background - like Hangouts, for example.)

Plan C:

Ping the site...

ping www.superuser.com

Pinging superuser.com [198.252.206.140] with 32 bytes of data:
Reply from 198.252.206.140: bytes=32 time=39ms TTL=52
Reply from 198.252.206.140: bytes=32 time=40ms TTL=52
Reply from 198.252.206.140: bytes=32 time=41ms TTL=52
Reply from 198.252.206.140: bytes=32 time=42ms TTL=52

Ping statistics for 198.252.206.140:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
   Minimum = 39ms, Maximum = 42ms, Average = 40ms

Plan D:

An old Windows adage, but when all else fails, reboot.

Useful site: http://www.downforeveryoneorjustme.com/ - check the sites you are trying to access.

Another useful site: http://downdetector.com/ - Reports of outages on services and websites.

2
  • 1
    Or stop the DNScache service , and leave it stopped, to test. The DNScache service (at least on 7) is only for the cache itself. Myself I have run for months with the cache service disabled, on a fast connect. With the DNs cache service stopped, and the fail still happening, a person might start looking beyond the MSsystem, to things like the router , or the browers features instead.
    – Psycogeek
    May 3 '14 at 12:11
  • 1
    you might have to open the cmd in administrator mode in a case if you get an error like "access is denied". For windows 8.1, press Win + Q, type cmd, right click on the cmd in search results and click run as administrator.
    – Omar Tariq
    May 4 '14 at 6:09
2

Jay M. explain few ways how to resolve this but here is a bit more light on this issue

Google Chrome has it own DNS Cache. You need to restart chrome browser as quickest solution.

Reason is that this cache is build to speedup your HTTP requests. Of course this is the case on MS Windows platform. Misrosoft took some effort to build network profiles to meet some requirements related to LAN you are accessing at the moment. So in case when you are at public place DNS Client windows service will be stopped so it won't cache any DNS resolution.

Why? Because same service is used to cache hosts around you using network discovery service.

From googles stand point it is overhead so they build their own cache in order to lower round trips to DNS resolver which some times may be expensive when you have poor network connectivity.

2
  • 1
    so, that's an explanation. Thanks for that. But what would be permanent solution? I'm still facing this issue.
    – Omar Tariq
    May 26 '14 at 15:07
  • The resolution depends on your DNS server (the one you are using), what are the websites you are access, are they available all the time, if they are using services like DynDNS then the issue is with them since public IP is changing constantly. Some things can be "fixed" on your box but some can be fixed only by website administrators. Surely it is case by case scenario and there is no standard cure unfortunately May 29 '14 at 12:05
2

I struggled for a month, had to flush dns all the time in 3 computers. I changen DNS server to googles DNS server. Primary 8.8.8.8 and secondary 8.8.4.4. This solved my problem. Google how.

1
  • This was working for me. My DNS was defaulted to my routers IP so I changed the DNS to the IPs above. How did you came up with this?
    – ruelluna
    Oct 12 '16 at 6:29
0

I tried all of the "solutions" on the web. Finally, I went into the administrative tools for windows and disabled the DNS client. So far problem solved, but time will tell.

0

Not the answer you're looking for? Browse other questions tagged or ask your own question.