I bought a home security camera. It's a Dlink DCS-5010L

It has a motion sensor feature. And every time that motion sensor is triggered, it takes snap shots. And it has an option to send those snapchats via ftp.

So I downloaded Filezilla and configured it and then I went onto the set up page of my security camera and entered the settings for the FTP server.

I'm on Windows 8. I'm using Filezilla.

My Filezilla settings are as follows:

Port: 14147

I have one user account.

Username: Aaron
Password: (None) I left it blank for testing purposes.
Max connections: 3

Everything else is unchanged

My home directory is D:\

The directory I want the snapshots to save to is D:\DLINKCameraRecordings\

I saved my settings.

And on the ftp settings for my camera are

Host name: (static IP for my desktop)
Port: 21
Username: Aaron
Directory Path: D:\DLINKCameraRecordings\

One thing I'm confused about is the port is 14147 but when I run the server, it listens on port 21. That's why I put port 21.

And then filezilla does this

Creating listen socket on port 21...
Server online
(000079)5/3/2014 14:03:21 PM - (not logged in) (> Connected, sending welcome message...
(000079)5/3/2014 14:03:21 PM - (not logged in) (> 220-FileZilla Server version 0.9.44 beta
(000079)5/3/2014 14:03:21 PM - (not logged in) (> 220-written by Tim Kosse (tim.kosse@filezilla-project.org)
(000079)5/3/2014 14:03:21 PM - (not logged in) (> 220 Please visit http://sourceforge.net/projects/filezilla/
(000079)5/3/2014 14:03:26 PM - (not logged in) (> USER Aaron
(000079)5/3/2014 14:03:26 PM - (not logged in) (> 331 Password required for aaron
(000079)5/3/2014 14:03:32 PM - (not logged in) (> PASS 
(000079)5/3/2014 14:03:32 PM - aaron (> 230 Logged on
(000079)5/3/2014 14:03:40 PM - aaron (> TYPE I
(000079)5/3/2014 14:03:40 PM - aaron (> 200 Type set to I
(000079)5/3/2014 14:03:40 PM - aaron (> CWD D:\DLINKCameraRecordings\
(000079)5/3/2014 14:03:40 PM - aaron (> 550 CWD failed. "/D:/DLINKCameraRecordings": directory not found.
(000079)5/3/2014 14:03:40 PM - aaron (> QUIT
(000079)5/3/2014 14:03:40 PM - aaron (> 221 Goodbye
(000079)5/3/2014 14:03:40 PM - aaron (> disconnected.
  • It's very difficult to understand your question and what the problem is. It'd help if you organized it for easier reading. And please read the formatting help -- right now, your question is a mess. – Daniel Beck May 3 '14 at 21:13
  • I tried formatting it. I pushed enter after every line. And then when I posted the question it comes out as one paragraph. Then I tried using <p> tags and it still isn't formatting it. – Alpaca May 3 '14 at 21:22
  • @brandon Try pressing enter twice - does it work, maybe format this as code – ᔕᖺᘎᕊ May 3 '14 at 21:30
  • It seems Filezilla says D:/DLINKCameraRecordings doesn't exist. Does it exist? – Oriol May 3 '14 at 22:02

Port 14147 is actually the administrative connection port that Filezilla uses to connect to the management interface. You should not ever have to use that port for anything.

You seem to be connecting just fine to FTP, but when it tries to CWD to that folder on your D Drive it says

550 CWD D:\DLINKCameraRecordings\ (000079)5/3/2014 14:03:40 PM - aaron (> 
550 CWD failed. "/D:/DLINKCameraRecordings": directory not found.

So, just because you ahve created that folder, you might need to go into the admin panel for FileZilla FTP server and make sure that d:/DLinkCameraRecordings is set as the default folder for the user aaron, and make sure that user has write permissions for that folder as well.

Also, d:\DLinkCameraRecordings is not a valid FTP path. Unless you have configured FileZilla in some strange way, all of the paths are relative and not absolute. This means you should have a \DLinkCameraRecordings folder without the drive letter designation.

If that does not work, I suggest shortening the folder name to something simple to make sure something is not being mistyped somewhere.

Also, try adding a password for your aaron account on FTP. It could be the FTP client on the camera end is having issues with no password for a non-anonymous account, but it does not seem likely. This is more just a good practice to always make sure you give passwords to accounts for services like FTP

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.