1

I have already installed vim-powerline in vim using vundle, but I am having trouble installing any of the pre-patched powerline fonts in the Lokaltog/powerline-fonts github repo. When I download one of the fonts, I double click the file, but instead of the fontbook preview window with the option to install popping up, fontbook opens up like it normally would if selected from the applications directory. I also tried to validate the font file, but fontbook gives me the white x/red stop sign symbol and says there is something wrong with the file. The option to install was there, however, so I installed it. The file ended up in /Library/Fonts/ but it would still never show up in fontbook. I am trying to select this downloaded font in my terminal window text settings, but even after this install it still won't show up in the options to change font in the terminal text settings. I've seen a bunch of information online of getting vim to recognize the already installed fonts, but haven't found anyone with this particular issue yet. Is this a mavericks issue, or am I missing something. Any help is really appreciated.

  • What font exactly? What file did you try to open? "says there is something wrong with the file" what does it say exactly? Any reason why you ask here and not there? – romainl May 4 '14 at 13:48
  • I wasn't sure if this was a problem with powerline. Actually, I don't think it is. I have found other people online complaining about adding new fonts to font book in Mavericks. I am trying to add Inconsolata for powerline. – SherMM May 4 '14 at 16:11
  • When I try to add this font took by double clicking it after download, I see some transparent windows flash across the screen quickly, but never fully appear. Then, the font book application opens up, with no information about the new font. So, I go to the font book menu and try to validate the font. When I find inconsolata and click to validate it, a screen pops up with an error that says: "1 serious error was found. Do not use this font." – SherMM May 4 '14 at 16:12
  • I can still install it by checking the box next to the font, but it never shows up to be selected in font book. It isn't an option in fonts for terminal.app either. It is installed to the /Library/Fonts directory. – SherMM May 4 '14 at 16:12
2

I figured out how to install these fonts into fontbook finally. I just made a ~/.fonts directory, cloned the powerline-fonts repo into this new directory, then ran fc-cache -vf on the ~/.fonts directory, cd'd into the cloned repo, cd'd into one of the available font directories, then just opened the .ttf or .otd file with fontbook (default), and the expected preview screen with the option to install was available. I then was able to change the font in my terminal and can now see the powerline glyph symbols and colors.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.