I'm trying to install Windows and the bios should be set to UEFI mode. The problem is that all SATA devices aren't showing up (shows as if there aren't any) so I can't boot from the installation CD (it's just not there).

The weird thing is that when set to LEGACY mode they all show up..

SATA mode is set to AHCI and I'm on Lenovo Y510P. I have a Linux OS installed that is accessible only when BIOS is in LEGACY mode (otherwise the hard drive it's on is not available)

I also tried reseting the BIOS settings which didn't help..

Comment please if more details needed

Extra details:

  • Computer model: Lenovo IdeaPad Y510P (not overcloacked)
  • Installed Linux OS version: Linux 3.7-trunk-amd64 x86_64
  • Trying to install Windows: Windows 7 Ultimate 64bit
  • BIOS Information:
    • Vendor: LENOVO
    • Version: 74CN26WW(V1.07)


Using user1608638 answer and suggestion of using the USB flash drive as the boot device instead of the CD/DVD method I succeeded in installing Windows 7! (Thanks alot user1608638)

  • We need more info about your computer model (overclocked?), the disk(s) and the boot (DVD or USB). If you have more than one disk, try to disconnect it and all USB devices possible and try again. If no go, try a Linux live CD. You could also try to reset the BIOS to defaults.
    – harrymc
    Commented May 6, 2014 at 18:48
  • 1
    I tried reseting Bios to defaults, no overclocking, tried both DVD and USB - both not showing up and working when in UEFI mode. Tried disconnecting everything - not helping. What should I try with the Linux Live CD? Commented May 6, 2014 at 18:59
  • See if Linux can see the disks. Try also to find a BIOS update (self-booting if there is no OS at all). It's hard to be precise without more info about your setup.
    – harrymc
    Commented May 6, 2014 at 19:19
  • I can't use Linux Live CD while in UEFI mode because the CD reader drive is not available. I forgot to mention that I have a Linux OS installed which works great in Legacy mode but again, not available in UEFI because the hard drive it's on is not available (available = showing up). What further details would you like to know about my setup? Commented May 6, 2014 at 19:22
  • 1
    I would like the involved computer model, disk(s) model, BIOS version, Linux version, Windows version (I assume 64-bit). You can boot Linux also from USB, but if Linux is working you could use gdisk to convert the disk to GPT (disk lose possible). Note that Windows might not like a mix of MBR and GPT inner hard disks.
    – harrymc
    Commented May 6, 2014 at 19:32

6 Answers 6


I wonder, is the windows image efi bootable? If the image is not efi bootable you can only boot it using legacy. This goes at least for USBs, and I would assume it does the same with CDs. You can check this by seeing if the file 'BOOTX64.EFI' via the path \EFI\BOOT\ is available on the CD.

Also, is it a must for you to install it with this CD? If not, you could try install windows by using a bootable USB, to make sure that the drive is GPT. If you already have a windows machine and a USB device available you can simply use a windows ISO, and use the program rufus to create a bootable usb. Otherwise, maybe this can be of any help?

  • @user1608638, Is it possible to solve it then, by copy/pasting the required EFI folder and files in? E.g. per iplanetforum.com/…
    – Pacerier
    Commented Apr 23, 2015 at 21:05

When booting the Windows 7 installation DVD you get the message :
"Windows cannot be installed to this disk. The selected disk is of the GPT partition style."

So the disk is already GPT (why if it's only 1TB?).
However, installing Windows 7 64-bit on GPT can only be done in UEFI mode.

Conclusion: Either your Windows 7 DVD isn't 64-bit or your BIOS doesn't support UEFI well-enough.

What you can do is :

  1. Verify that the Windows 7 installation DVD is the latest 64-bit version with SP1 and try again.
    Delete all existing partitions, create a new one and format it.
  2. Convert the disk to MBR using Linux. See the article
    How to Convert a GPT disk layout to a MS-DOS/MBR layout without data loss.

You might be able to convert the disk to MBR from the Windows 7 installation disk:

Method 1 (non-destructive in theory)

  1. Boot up to installation DVD/CD.
  2. Click install but don't follow through.
  3. Press SHIFT-F10 to bring up console.
  4. Type "diskpart"
  5. Once inside diskpart type:
    -> list disk (find the one you want to convert)
    -> select disk 0 (select the one you want from the list)
    -> convert mbr (should take a second or two)
    -> quit
  6. Continue with install

Method 2 (destructive)

  1. Boot up to installation DVD/CD.
  2. Click install but don't follow through.
  3. Press SHIFT-F10 to bring up console.
  4. Type "diskpart"
  5. Once inside diskpart type:
    -> list disk (find the one you want to convert)
    -> select disk 0 (select the one you want from the list)
    -> clean (wait an hour or so until done)
    -> quit
  6. Continue with install

Method 3 : GParted (destructive)

  1. Launch GParted on the disk.
  2. If any partitions are mounted (as indicated by a lock or key icon), unmount them.
  3. Select Device -> Create Partition Table.
  4. Click Apply.
    The disk should now use MBR. Do not create partitions within GParted, do this instead with the Windows installer.

Just remember that any such manipulation can destroy the data on the disk.

  • I will try and follow your instruction to change the partition style to MBR and update. Even though your answer is properly written and explains everything needed to do that, my question was mainly about the fact that while in UEFI mode - all the drives are not available. This is not because my "BIOS doesn't support UEFI well-enough" - before installing the Linux OS I had Windows 8 running without problems while in UEFI mode (The computer ships with it) -> So I did upvote your answer but not yet accepted it. Thanks for your effort to help me solve this Commented May 7, 2014 at 7:25
  • The other explanation is that the Windows boot DVD doesn't have a driver for the hard disk. The Lenovo specs for Y510p don't specify the disk type, except to say that there are 3 possibilities. In that case you will need to either supply the driver during boot or slipstream it into the boot media. Lenovo Support has a driver for Intel Rapid Storage Technology for Windows 7.
    – harrymc
    Commented May 7, 2014 at 8:24
  • I might have not clarified it enough - the drives not showing up - that's in the boot menu, not when trying to install Windows; I can't even try to install it while in UEFI mode because there are no drives in the boot menu to boot from. When I change the BIOS to Legacy mode I can see the drives in the boot menu and therefor boot the installation CD - at that point the installation disk does show the drives but with the GPT error which you gave a suggestion on how to solve. My main question though, is how to fix that the boot menu shows no drives while the BIOS is in UEFI mode. Commented May 7, 2014 at 8:34
  • That's a problem of the BIOS not supporting 64-bit in UEFI mode. I don't think anyone except Lenovo can fix that. You could try and contact their Support - they might have a secret BIOS update or parameter. Otherwise, converting to MBR is the only advice that I can think of.
    – harrymc
    Commented May 7, 2014 at 10:53

Try changing the SATA devices (or just the optical drive) from AHCI mode to whatever legacy/compatibility mode is available there, leaving the BIOS in UEFI mode and see if that changes anything.

  • Tried that (the other mode is called Legacy) - not working. Commented May 4, 2014 at 18:11

Change your SATA to ACHI in BIOS. That did the trick for me.

  • 2
    Welcome to Superuser:- Your answer to a question that has an accepted answer will need some more detail to be supported by readers. How do you change the SATA etc, what systems are you using etc. Your answer can be useful to other readers that the accepted answer did not work for but requires detail. Please take a couple of minutes and read:- help center .Answering: How to Answer, again welcome to superuser and i hope you keep coming back.Thankyou
    – mic84
    Commented Oct 11, 2018 at 9:09

I have the same problem, and I know it's NOT the mobo or bios issue, as I have a brand new ASUS A-170A mobo with latest bios, and it was working fine on the first install, but then I installed Windows 10 "after" the uefi windows 7 was already working, and that's when the bios went all crazy (well, I guess it's efi...not essentially a bios anymore, right?) and didn't recognize any of my sata drives in uefi mode any more, even though I had just had it there previously, and installed windows 7 and windows 10 from a UEFI enabled DVD/BD drive...so installing windows did something to the bios (efi) proving that it's no longer a completely separate bios any longer when running UEFI. (which I've read, but DON'T understand ) So if anyone has any help other than lame attempts at getting points from "NON" answers, I'd really appreciate it.

In fact, I installed Windows 7 first from UEFI enabled DVD drive, and installed windows 10 from USB drive...so I don't know how that could have done anything, but it's the only thing that wasn't specifically on the boot menu at a UEFI device. hdd is GPT, and has working EFI partition, and even that doesn't show up as a UEFI drive, even though it clearly is. so f'ing confusing...


I gust had a similar problem on an HP Z420. It helped just to copy the boot loader efi file to a standard location - copying /EFI/grub_archlinux/grubx64.efi to /EFI/Microsoft/Boot/bootmgfw.efi as described in archwiki

Its possible this may also work for Lenovo's systems if they hardcode the paths for the UEFI/OS boot manager the same way.

  • Welcome to Super User! Please edit your post to include the essential elements of the linked material. Good answers include specific instructions (not just links to them) and an explanation as to how/why the answer addresses the OPs question. Commented Jan 3, 2018 at 21:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .