0

For a little over a week now I have been having an issue where some games rendered using DirectX have been crashing after a small period of time. Usually the result is similar to an immediate system shutdown but with the lights still on and fans still blowing.

GuildWars 2 and Space Engineers are the two primary games the crash occurs in. Since finding out the crash occurs in more than one game I have thoroughly checked for heat issues leading up to the time of the crash using both hardware monitors and my own hand to see if it is overheating and I can safely conclude it is not.

Suspecting the PSU, I have used a multimeter to detect the voltage being supplied to the video card 6-pin power, as well as a molex connector on a different rail. The 6-pin video card power connectors showed 12.4v. The 5v power on the molex connector showed exactly 5v. I do not appear to have a dying power supply.

I have downloaded some benchmark tools to see how reproducible the crash is. Furmark 1.13.0, Unigine Heaven 4.0, and Unigine Valley 1.0 are the benchmark tools I have used for this. I have ran Furmark for over 30 minutes with GPU load sustained at 99%-100% the entire time and wasn't able to produce a crash.

Next I moved on to Unigine Heaven benchmark with resolution at 1920x1080, quality at Ultra, and DirectX11 as the renderer. The test lasted the expected ~6 minutes before crashing. If I set the quality to high instead this benchmark doesn't appear to crash after ~15 minutes regardless of renderer. Unigine Valley benchmark I couldn't get to crash on high or ultra settings, at 1920x1080 resolution, and DX9, DX11, or OpenGL renderer.

I have also attempted to load up much older games to see if I could find any more patterns. I was successfully able to play Unreal Tournament (original) and Unreal Tournament 2004 for over 30 minutes each with no issues. I also launched Halo PC and was able to play that for over an hour, again with no issues.

Suspecting a faulty DirectX install I attempted look at DirectX Diagnostic tool to see if it was reporting any issues, but there were none reported. I attempted to install DirectX but it reported that I already have the newest version. I attempted to alter the DirectX version registry key on my system to trick it into installing anyway, but it still insisted I had the newest version. I have also already installed the newest graphics driver for my video card. I used the cleaning utility from AMD, and rolling back what remains until I saw a Microsoft provided driver in device manager to ensure a clean install.

Most recently I have also attempted to reduce the graphics settings to low in GuildWars 2 and Space Engineers hoping the crash could be worked around until a more permanent solution could be found. However doing so made zero impact on the crash behavior.

Where do I go from here?

  • Processor: AMD Phenom II x4 965
  • RAM: 16GB
  • Video Card: Gigabyte AMD Radeon HD 7970 3GB
  • Video Driver: 13.251.0.0 dated 12/6/2013
  • Power Supply: Raidmax Quantum RX-700 700w ATX12V V2.2
  • OS: Windows Vista 64-bit with SP2
  • use this trick to install the latest 14.4 driver under Vista: forums.amd.com/game/… and look if this fixes the crashes. – magicandre1981 May 5 '14 at 4:22
  • I attempted to do so and it made no difference in the crashes. – Mako_Energy May 8 '14 at 0:27
  • when the Error report kicks up, click on details, copy them and post them here (use code formatting to make it readable) – magicandre1981 May 8 '14 at 4:08
  • There are no error reports. It works, then black screen. I have to reboot. Event viewer shows nothing. No blue screen. – Mako_Energy May 8 '14 at 4:38
  • what is the temperature at the freeze time (GPU/CPU)? Also, does the light on the keyboard toggles if you press the CAPS LOCK key. – magicandre1981 May 8 '14 at 19:09
0

As a part of troubleshooting I tried to put a different video card into my computer to see if the behavior would change. The video card did not use 6-8 pin external power and when I tried to start up my computer it wouldn't post. Knowing it was a good video card a friend provided a power supply tester to check the motherboard power. When used the testing device flickered.

So I ended up buying a new power supply and the issue is resolved. Unusual though that no issue was detected on the 12v rail supplying power to the video card, but power from the slot was faulty.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.