I'm trying to create a new local user in Windows 8.1 x64. This user will be used to host an IIS app pool and connect to a SQL Server instance. However, when I try to start the app pool or login with the user, the user profile service gives me an error saying the profile cannot be loaded.

There's no directory/folder created in C:\Users for that local user. And Windows Event viewer shows these errors:

Entry 1:

Windows cannot find the local profile and is logging you on with a temporary profile. Changes you make to this profile will be lost when you log off.

Entry 2:

Windows cannot log you on because your profile cannot be loaded. Check that you are connected to the network, and that your network is functioning correctly.

DETAIL - Only part of a ReadProcessMemory or WriteProcessMemory request was completed.

I know this is a problem specific to Windows 8 and higher. But no one can seem to find a solution this problem.

I see the same set of problems here:

User profile service service failed the login. User Profile can not be loaded


Process described in full here

Basically when creating a user you have to (counter intuitively) choose for 'Create a new account' when asked for your microsoft live account and in the next step choose for 'sign in without microsoft account'.

| improve this answer | |

There is an easy way to switch to a local account in Windows 8.1 Pro RTM. Go to the Charms Bar and select Settings. At the bottom right select Change PC Settings. Then on the left hand side select Accounts. Below your Live account select Disconnect. This will open a box to create a local account.

| improve this answer | |
  • Right, I did that, but the user created in this manner still cannot login. I get the same error. – abjbhat May 6 '14 at 4:44
  • Please view a tutorial at techrepublic.com/blog/windows-and-office/… – NoName May 6 '14 at 14:05
  • I know, I did exactly that.. but I get the error mentioned above. – abjbhat May 6 '14 at 14:37

Alright, I've found the problem and the solution. The problem is that the

C:\Users\Default folder wasn't inheriting permissions from the parent. The fix is quite simple and outlined on this technet question

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.