I am trying to install Windows 7 Professional x64 from a bootable USB stick. I have used the Windows 7 USB DVD Download Tool to create the media from an ISO.

The machine boots from USB fine, and enters the Windows installation wizard but then I get an error stating:

A required CD/DVD drive device driver is missing. If you have a driver floppy disk, CD, DVD, or USB flash drive, please insert it now.

I have tried setting the SATA controller in the BIOS to both AHCI and ATA but neither appear make any difference.

I've also tried both the USB 3 and USB 2 ports with no difference.

I've also tried to use the files from an official Dell recovery CD as this is a Dell laptop but again, no dice.

All this because there's no optical drive in the machine!

Dell Vostro V131 / i5-2450M / BIOS A04

Can anyone offer any advice please?

up vote 3 down vote accepted

Is the USB stick USB3? This error is encountered when you try to boot Windows 7/8 from a USB3 port because it does not have the drivers loaded to get past the part of the install where it prompts you to select the disk to install to. Are you SURE you have used a USB2 port as well? Do you have any devices hooked up to the USB bus at all other than the thumbdrive? I could see that causing issues during install as well.

  • 1
    did my suggestion end up resolving your issue? If so, please say what the solution was so if someone else has the same issue it can be resolved. – Richie086 May 8 '14 at 15:53

as I've searched a Thousand pages looking for a solution, I've found that the real bad guy here is really the USB 3.0 drivers that DO NOT come bundled in the Windows boot disks and it gets lost searching for its own installation files after booting...

There are 2 possible solutions: switch to a USB 2.0 usb stick and it goes like a breeze.... OR.... if you are like me and have ONLY 3.0 ports, download the 3.0 controller drivers and unzip all its files to the C: drive

click search, go through the drivers you downloaded and click next, it'll find the drivers, "install them" and come back with the same error again.

THIS TIME, since the drivers ARE installed, you should unplug the stick and plug it back in... click next and it should work.

Easy like a fatality...

This message happens when you try to install Windows 7 via USB flash drive and use the USB device on a USB 3.0 port. Windows 7 doesn't support USB 3.0 out of the box, so you must inject the USB 3.0 drivers into the Boot.wim with DISM first.

dism /mount-wim /wimfile:boot.wim /index:2 /mountdir:mount

dism /image:mount /add-driver:"usb3" /recurse

dism /unmount-wim /mountdir:mount /commit

enter image description here

Now copy the modified boot.wim to the flash drive.

Source is this SU answer by magicandre1981.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.