I have already read a lot of posts about enabling sudo-access for a specific user but those couldn't help me so far.
The situation is:
I'm running Debian Testing. On the system there are only two accounts: 'root' and a user account 'benny'. The user 'benny' should be able to run commands with root privileges using sudo (of course I installed sudo first), which is why I edited the '/etc/sudoers' file using visudo as follows:

Defaults        env_reset
Defaults        mail_badpass
Defaults        secure_path="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"

# Host alias specification

# User alias specification

# Cmnd alias specification

# User privilege specification
root    ALL=(ALL:ALL) ALL
benny   ALL=(ALL:ALL) ALL #<<<<<<<<<<<<<<< EDIT HERE!

# Allow members of group sudo to execute any command
%sudo   ALL=(ALL:ALL) ALL

# See sudoers(5) for more information on "#include" directives:

#includedir /etc/sudoers.d
ALL ALL= NOPASSWD: /usr/sbin/g15daemon

This did not work at all - when issuing the 'sudo' command it keeps saying 'benny is not in the sudoers file. This incident will be reported.' So I added benny to the group 'sudo', as it was often suggested:

usermod -aG sudo benny

After a re-login as 'benny' the command



benny cdrom sudo fuse

which seems fine to me. Also

 cat /etc/group | grep sudo 



However if I try, for example

sudo apt update

it still keeps saying that benny was not in the sudoers-file.
I've really read a lot about this issue and everyone just advices one of the two steps, I mentioned above.
What am I missing here? I gues it's something really stupid, but I do not see it. Any help is appreciated! Thanks in advance!

  • 1
    Have you logged out and logged back in?
    – hookenz
    Commented May 6, 2014 at 22:34
  • By the way, no need to add benny to sudoers, just place him in the sudo group which you've already done. The only reason to put benny specifically in sudoers is if you want him to have a different set of privileges than the sudo group. In your case they are the same.
    – hookenz
    Commented May 6, 2014 at 22:35
  • Yes I did, I even restarted the whole system - just to make sure... Commented May 6, 2014 at 22:35
  • 1
    Have you tried creating a new user and adding that user to the sudo group, to see if that works? This may help to narrow down where the problem is happening. Commented May 14, 2014 at 23:27
  • 4
    What does "sudo -U benny -l" return when run as root? I suspect a typo or something similar in the sudoers file. Also is there anything in /etc/sudoers.d?
    – Bram
    Commented Nov 21, 2014 at 17:04

2 Answers 2


I pulled down the source code for sudo and it appears that the way this could happen is if your sudo is configured to use LDAP or SSSD methods to determine permissions. If either of those is available, it will be checked before the file method. This probably only makes sense if this machine was set up for you in a corporate environment or something? In these cases, the error message is a bit inaccurate as it still refers to the sudoers "file".

I've never used either of those for this but it appears they would be configured in an /etc/sudo.conf file, so you could see if you have such a thing. Looking at man sudo it mentions an LDAP plugin and man sudo.conf gives info about plugins are configured FWIW.

  • Thank you for suggestion! Unfortunately I have never found out what was causing that issue. By now I have reinstalled the OS (several times) and it never happened again. Also other systems I set up never had this issue again. At that time, the system I was talking about was my private PC at home, so it was not set up for a corporate environment. Commented Mar 4, 2018 at 14:28

I've had a very same problem and "solved" it by remove, purge and install of a sudo.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .