2

.NET framework 4.0 install fails on Windows XP professional version 2002 SP3:

I tried to run setup using "run as..." to make sure the admin rights are used ("protect my computer..." tick was deselected of course). I tried everything: installing using online/offline setup, windows update.

install goes a little and then "rolls back" and says:


Installation did not succeed

.NET Framework 4 has not been installed because:

Fatal error during installation.

for more information about this problem, see the log file.


the full log: http://pastebay.net/1433771

Any ideas?

EDIT1: I have found this in the log:

"BlockIf: You must install the 32-bit Windows Imaging Component (WIC) before you run Setup. Please visit the Microsoft Download Center to install WIC, and then rerun Setup...."

So I found it, and launched "wic_x86_enu.exe" - but it said:


WIC Setup error

Newer version of update is already on the system.


I have already installed:

.NET framewrok 2.0 SP2

.NET framewrok 3.0 SP2

.NET framewrok 3.5 SP1

but I need 4.0 .

EDIT2: another attempt and it's log. (this time better copy of log file):

http://pastebin.com/gmGfbM9a

(copy to notepad and save as .htm and open with internet browser).


I have tried all the solutions I could find - and nothing helped.

I have found something weird: when I formatted the hard drive and installed windows xp again - the .NET framework 4.0 installed ok, but when I plugged my 100Mbit internet cable - the operating system kind off "locked itself" and the bug returned - I could no longer install .NET framework 4.0 again. There was no reason for that to happen, for example I have windows server 2003 in local network, but I don't have active directory enabled on it or anything like that - the server just has some folders shared and thats all (all server's "features" are default). I had the second pc with the same problem - with XP on it too.

This seems like the bug of Operating System to me. I couldn't find what was causing the problem. After many days I gave up: backuped everything, formatted HDD and installed Windows 7 professional 64bit. .NET framework 4.0 installed with no problem on it.

  • The log seems truncated and incomplete. Perhaps use pastebin? As it stands, it's not very useful. – Nathan C May 6 '14 at 23:58
  • @NathanC included "raw" log file in edit2. should be no mistakes in copy-paste. – ctrl May 7 '14 at 0:20
1

Your log file is outputting an error code that may be caused by a corrupt MSI installer component. You can run the FixIt tool off this page to try and repair it.

0

"MsiInstallProduct(E:\06bedaa1f86113093c897b5b3fabfc\netfx_Core_x86.msi, EXTUI=1
[5/7/2014, 3:2:31] Returning IDOK. INSTALLMESSAGE_ERROR [There is a problem with this Windows Installer package. Please refer to the setup log for more information. "

There's your fatal error.

Reffer to the answer here: http://social.msdn.microsoft.com/Forums/vstudio/en-US/ce7dbfe2-8923-4f01-9a48-9854dc847a76/help-net-framework-4-not-installing?forum=netfxsetup

Hope it helps.

-2

I had the exact same problem and the way I solved it is by right clicking on Program Files and adding myself as a user in "Security" and giving myself full permissions. I also clicked on the Advanced tab and made myself the owner of Program Files. Don't forget to check the box for all subcontainers, etc. before hitting apply.

I did this with my C drive where all these files are located, but even though I did that, Program Files did not list me as the owner. Instead it had Administrator as the owner.

My user account is an Administrator account, but even though I am an administrator, all system files will be owned by the System Administrator (Administrator) until you take away ownership and/or add yourself as a user with full priviledges.

So the installer could not access Program files and other system folders to "do its thing" and hence it came back at me with a "Fatal Error" message. What else could it do? It's like inviting someone to enter a house that is not yours, LOL. You've got to be the owner and have full priviledges to let someone go in and "do its thing".

Try this and I'll betcha it works.

  • 3
    No no no, don’t even think of doing this. This breaks all sorts of important security measures. This absolutely not required on a healthy system. – Daniel B Jul 31 '14 at 15:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.