I frequently type Japanese (and a few other languages) using an English keyboard using stock Windows 7 Starter with its standard Japanese Input Method Editor (IME).

Japanese keyboards have two or three special keys to switch "Input Mode", which western keyboards lack.

The functionality of at least some of these keys is available through combinations of modifier keys when using the English keyboard:

  • SHIFT + CAPS LOCK
    toggles between alphanumberic and hiragana input
  • Right ALT + CAPS LOCK
    switches to katakana input
  • Right CTRL + CAPS LOCK
    switches to hiragana input

But recently I've found my keyboard can get stuck in "Full-width alphanumeric" (Like this).

I can change modes using the above hotkeys, but I can't change back to "Half-width alphanumeric. The normal hotkey to change to alphanumeric always changes to Full-width, no matter whether caps lock is engaged or not.

I can switch using the mouse and GUI but this interrupts my touch typing speed and causes unwanted distractions.

This could be the result of a bug, but if there is a hot-key combination I'm unaware of for switching to Half-width it would well be worth knowing.


UPDATE

I definitely have not changed my preferences or settings for the Japanese IME hotkeys. I swear they were the default settings but have become changed without my intervention, possibly during the last Windows Update.

Besides the key combinations I mentioned earlier, I have discovered that I can toggle between hiragana and alphanumeric input now with this combination and no other I can find, including the old combination I used to use:

  • ALT + `

I'll start adjusting to this and if I find no problems other than just being different I'll post it as an answer.

This totally happened to me, too!

And this reply is really late, but I kind of found fixed my problem today.

I started toggling my language settings in language preferences in the control panel, then selection options for the Japanese language. I chose options from the input methods, and then advanced settings for Microsoft IME. In the autocorrect tab, there is a scroll space where you can specify whether to use half or full-width based on the character kind, and under alphabet, I switched it to always use half-width. Now when I use shift+caps lock, it's always half width. I don't know if there was a hot-key combination that switched that setting.

Hope that was somewhat helpful!

In the "Advanced Settings for Microsoft IME" dialog you can change all keyboard shortcuts on the "General" tab under "Editing operation and behavior" "Key template:" "Advanced".

The only settings I usually change is mapping Ctrl+SPACE to "IME ON/OFF" in all columns and Ctrl+K to the first (yes there are two...) "Katakana" functions, which turns everything I entered so far to Katakana, like cmd+K does on the MacOS's IME.

There was an IME Update recently, maybe that triggered this half/full width problem, but I have found a fix.

Search in the start menu "IME", then click on "Settings for Microsoft IME". In the next windows you click on "advanced" > Tab "AutoCorrect". On the bottom left side choose "Alphabet" and the on the right side just next to it "Always use Half-width".

I had the same issue, and I am also sure I never changed the default settings of the IME.

Since the proposed solutions with AutoCorrect seem like a hack to me, I tried my chance by clicking the Reset button for the IME settings, and guess what... it worked!

Here is where you can find the Reset button: Right-click on the language bar, click "Properties", select the Japanese IME in the list, then click "Properties", go to the "General" tab and click "Reset".

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.