0

I have rather simple Access 2010 database. I needed to add a new field to one of the tables. While in Datasheet View, I Clicked the "Click to Add" column header and defined a new field.

I went to one field, in the existing records, and then I typed in a value into the text field. After entering my first data change, I used the arrow keys to move to my next field that I need to enter. Nothing happened as I started to key in information. I moved to another field with data and I tried to modify it. Nothing happened. I closed and re-opened Access. I still can't modify any data on this table.

To be fair, I could have hit a mistaken hotkey. However, I can't find any documentation claiming that tables can be changed to a Read Only state. This seems to have just happened. I really need to update this information and I'd prefer to not have to create a new table since this is a table used in many queries and this is a DB I inherited. I've always found it to be a bit of a nightmare when managing other peoples access files.

FYI, this is not a linked table. It does appear in queries and on forms, and it does have reference fields. However, this table was modifiable and then, all of a sudden, it wasn't. What could I have done to cause this?

3

I just solved the problem. I would delete this question but the reason for the "Read-Only" state has me confused. Anyway, this is what caused the problem and how I solved it.

After adding a new field, I wanted to sort the data for easier data entry. However, after I sorted the data on a field that has a look-up drop-down, the table became read-only.

After I removed the sort, I could change the table again. I have no clue why Access behaves this way. If anyone can provide any insight into this behavior, I'll update my answer. If you see this issue, just remove your sorts and see if it fixes the problem.

protected by Community May 13 '18 at 9:39

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.