How to disable timeout in Firefox 29.0 / Ubuntu 14.04?

I have some web scripts that need time (up to 30 minutes) to complete.

The connection has timed out

The server at ... is taking too long to respond.

I tried to change network.http.connection-timeout to 99999 but timeout message still pops up after 1-2 minutes...

In previous version (28.0? not sure...) firefox used to wait forever which was OK for me (there was no need to change config)

Currently I run my scripts using wget but executing scripts in proper net browser was way more convenient for me.

  • 1
    Why not tweak the scripts to produce some initial output? The key to resolving this is to acknowledge the request was received.
    – Daniel B
    May 7, 2014 at 16:03
  • @DanielB I would rather like to stick with wget
    – Peter
    May 7, 2014 at 16:04
  • "I would rather like to stick with wget" ... "but executing scripts in proper net browser was way more convenient for me." So which is it that you want? To keep using WGET, or to have it work properly with a browser? May 7, 2014 at 17:34
  • 2
    @techie007: I want firefox to have no timeout, as asked in the question. I really do know workarounds (simple bash script with wget is one I currently use)
    – Peter
    May 7, 2014 at 19:03
  • Is a browser really the best way to access this page? Wouldn't curl/wget be better?
    – Zoredache
    May 7, 2014 at 20:28

2 Answers 2


In the list of changes between version 28 and 29 the key network.http.response.timeout was set to 300. Try to change it to something higher.

Ben Morgen wrote in his blog that this would work.

  • Nice one! Thanks! I am able to start scripts in firefox again!
    – Peter
    Jun 12, 2014 at 9:56

OK... at a guess,

open a new tab and go to about:config

Click "I'll be careful, I Promise".

Change the dom.max_chrome_script_run_time and dom.max_script_run_time to unlimited

Restart Firefox and see if this works for you. Remember to make a note of the old settings and you may want to revert this if it doesn't work. I've just tried it and I've had a recursive pointless loop running for a couple of minutes on my box without timing out.

Hope this helps

  • I think these settings are for javascript, preventing firefox to hang... I want to run 30-minutes long server side scripts, no javascript at all
    – Peter
    May 7, 2014 at 15:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.