I recently rebuilt my PC and installed Windows 8 Pro 64 bit - I was using it with few issues, and it was able access the shares on my Windows Home Server 2011 - although I had to enter user name manually as I was using Windows Live account for Windows 8.

Since updating to Windows 8.1 I can no longer access my shares on my WHS 2011.

I have tried various things to fix this, which I will list below, but one of the interesting things is I cannot even access the local machine via share.

My main PC is called Office and my server is called WHServer, so in explorer on my office PC under Network I see both WHServer and Office listed - click on either results in the message:

\\OFFICE is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.`

The specified network provider name is invalid.

If I try to navigate using IP, eg \\\Public or \\\Public I get:

 Windows cannot access \\\Public

Check the spelling of the name. Otherwise, there might be a problem with your network. To try to identify and resolve network problems, click Diagnose.

[Expanded Information] Error code: 0x80004005 Unspecified error

Clicking the Diagnose button finds no issues.

If trying to use net use m: \\[IP OR server name] I get:

System error 67 has occurred.

Pinging the hostname or IPs give responses as expected, as do visiting via http.

I have tried the following:

  • Tested via other Windows 8 (not 8.1) Laptop and everything still works there
  • Disabling firewalls on both local machine and server
  • Disabling AV on both local and server
  • Set HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters\RequireSecuritySignature to 0.
  • Allowing 40-56 bit encryption
  • Clearing credentials in Credential Manager - although when I delete one related user, it keeps comping back automatically
  • uninstalling and re-installing network

What should I try next?

  • You do understand is the loopback address right? I assume File Sharing is enabled on both installations?
    – Ramhound
    May 7, 2014 at 18:15
  • Yes I know that's the loop back address, I included the info to show that it was strange that the local machine could not even access itself via the loopback. File sharing is enabled on Office and Server machine. Cheers
    – Sean
    May 7, 2014 at 18:25
  • Not sure if this is a typo, but UNC paths begin with two backslashes.
    – Daniel B
    May 7, 2014 at 18:50

2 Answers 2


Client for Microsoft Networks was missing from the Network Adapter Properties.

Installed this then restarted and was OK again.


I was hawing problem with similar symptoms and tried many options from above. I also tried reinstalling "Client for Microsoft Networks" and that don't worked in my case.

In my case, in Device Manager was more that 300 hidden network adapters for mobile broadband network. After i uninstalled these adapters manually, network shares started working. Possible cause for so many duplicate adapters could be Cisco VPN client, which i installed and uninstalled before that problem appeared.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .