I'm running a debian system and today I ran aptitude safe-upgrade. It's been a while since I'd down that so it downloaded and installed a bunch of stuff including a new kernal image.

Everything appeared to install fine.

However after a reboot my system failed to start. Reporting a Kernal panic error and a "No filesystem could mount root, tried: " message.

When I booted in via a Knoppix live CD and run fdisk -l it shows my disk listed as sda1. This surprised me as it's an IDE drive and my fstab and lilo conf files are configured to use hda1.

I tried tweaking both fstab and lilo.conf (and running lilo) via the live CD. Now when I restart the system it drops into 'BusyBox' with a whole bunch of 'mounting' errors.

This got me wondering if for some reason a Knoppix live CD would show the disk as sda, but debian still requires hda? (By the way I did try this, but running lilo under the liveCD complains as there is no /dev/hda)

Edit: According to this article: http://www.mail-archive.com/debian-doc@lists.debian.org/msg11998.html It might be something to do with the fact the updated kernal supports a different naming convention for IDE drives.... Hmmm maybe this is a good time to ditch lilo and try and get grub running? Any other suggestions out there?


ok I found the answer.

As described here:


Kernel update 2.6.19 modified the IDE subsystem which changes the way modified that IDE devices are defined. So rather that hda the disk will appear as sda.

Drives appear as /dev/sda, /dev/sr0, the old devices names won't work. You will need to change your boot parameters and your /etc/fstab parameters in order to get a working system with the new drivers. Again, this only happens if you use the new drivers, the old drivers continue working as they did before.

My test system is running an older version of the kernel compared to what is on the Knoppix live CD. When booting from the live CD it uses the new kernel and hence the drive now appears as sda1

For people finding this page looking for a fix, the above website also states:

This means 2.6.19 may have two drivers for your PATA-based device: The old IDE driver under "Device drivers -> ATA/ATAPI/MFM/RLL support" and an alternative driver under "Device drivers -> Serial ATA (prod) and Parallel ATA (experimental) drivers" (along with the rest of the SATA drivers)

What one must you choose? Well, the safe option is using the old driver: The old drivers will continue working just as they did before. There'll be no changes if you continue using the old drivers.

  • this is right. the newer SATA driver supports PATA devices as well and will assign /dev/sda device names; the older driver assigns /dev/hda device names. i think i remember seeing a kernel boot parameter you could use to force the older driver, but i can't dig up that info at the moment. – quack quixote Nov 26 '09 at 6:32

One thing that happened to me was that I removed a drive and disk listing changed so the fstab couldn't find the right disk - could be something like that?

  • :) good suggestion, although in this instance it doesn't appear to be the case. – user9632 Nov 25 '09 at 20:26
  • 1
    this is why you should use UUID or LABEL in /etc/fstab instead of direct device links. – quack quixote Nov 28 '09 at 18:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.