I am using synergy to share my mouse and keyboard from a Windows 7 x64 server to a Mac OSX Mavericks client. Both machines are using the latest (1.4.17) version as of today.

I can connect fine, the mouse works, and the numpad works. However, pressing a normal key (for example, the "A" key) does nothing.

Enabling DEBUG1 on the client shows the following information on the log screen. For the letter A:

DEBUG1: recv key down id=0x00000061, mask=0x2000, button=0x001e
DEBUG1: mapKey 0061 (97) with mask 2000, start state: 0000
DEBUG1: key 0061 is not on keyboard

Both machines are set up to use japanese keyboard. In particular, I am using the Google IME on both machines. However, this problem happens even if I set the MS IME, Kotoeri, or even English US on both machines.

A previous solution was to change the Kotoeri preferences to use a non-English alternate keyboard. This setting was removed, and does not exist on Mavericks.

I have run into this problem in the past, and have seen that randomly playing with the keyboard layouts in both computers, rebooting, changing layouts, and even reconnecting the physical keyboard eventually solves the problem, and for some unknown reason, it stays solved...

Until I have to setup a new pair of computers about year later, and the problem appears again. This is completely reproduceable, but I have no definitive way of solving this problem. I am currently experiencing it again right now.

This issue has been brought up several times in other sites, with no definitive solution. I believe the other people who were experiencing the same problem somehow got it solved, but didn't know how, so they didn't write an answer.

If somebody knows of a deterministic way to solve this problem, please answer this question.

1 Answer 1


Once again, I got it solved, but I am not sure the solution is reproducible. This is what I did:

  1. While synergy was running (not sure if relevant), on the Mac OSX client, I set the English US keyboard source input. I then removed all other source inputs.

  2. I rebooted the client.

  3. When the client came back up, I launched synergy, and the keyboard was working. I then added back the Google Japanese IME, and removed the English US source.

  4. I rebooted the client.

  5. Now, for some magical reason, synergy is working perfectly with the Japanese layout.

  6. All this time, the Windows server was running with synergy. No reboot on the server side was required.

Notice that as far as Mac OSX is concerned, the settings are exactly the same before and after this entire process. Why this solved the problem is outside of my comprehension.

If somebody else is running into this problem, and these exact steps solved it, please write it down in the comments.

  • This answer is old but it still (magically) works. I don't use Windows, but I do use Synergy on Ubuntu as server (1.8.8) and Mac High Sierra as client (1.10.1). I created an account on SuperUser just to give you a +1. Oct 5, 2018 at 2:24
  • This seems to fix the issue for me as well, thank you. I tried different solutions that I found on other threads (conflicts with password managers, different keyboard layouts, etc.) but nothing solved it (or explained it).
    – Mokkun
    Dec 23, 2019 at 2:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .