1

I'm assembling a computer to use as an HTPC/small home server. Here's the hardware I have:

Motherboard Asrock FM2A88X-ITX+
CPU AMD A10-7700K (3.5GHz) Black Edition
RAM Kingston 2x4GB DD3 1600MHz HyperX Blu

Other than that I'm connecting with HDMI to my 50" Panasonic Led TV, using an Apple USB keyboard and a cheap USB mouse. I don't remember the brand of the power supply but it's a standard ATX 500W.

I have been trying to install Ubuntu from a USB stick (8GB). At first I had a lot of issues because it would fail when installing GRUB. Then I managed to install CentOS 6.5 (actually the only one that succeeded until now), and then after that I did manage to install Ubuntu 13.10. The last version would also fail.

To create the live USB stick I tried UNetbootin for Mac and Universal USB Installer for Windows.

Either way, when booting I have to add the "nomodeset" option to the boot parameters otherwise I don't even get to the installer. So that works, the installer doesn't complain and at the end it reboots. When Ubuntu starts booting I see a purple screen and then the screen flickers with some white noise until it settles on a black screen with a prompt on the top left corner.

I figured this must be the "nomodeset" option which is not enabled for the newly installed system. SO I boot with the live USB into "try" mode and edit the file /etc/default/grub and I add "nomodeset" to the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash.

This didn't help though. From all I read around the web (and lots of posts in askubuntu) this is related to the graphics card (in my case Radeon R7).

Then I tried changing splash to nosplash to see more details in the boot sequence. I didn't see much more but I did see that it crashed on a blackscreen with the following error:

usb 4-5: string descriptor 0 read error: -22

Searching in google for this doesn't help at all. It might have something to do with a faulty USB component, but I even tried disconnecting everything before booting, same results. Then I thought it might be the 2 USB3 inputs the motherboard has so I disabled USB3 in the BIOS just to be sure, still nothing.

What else can I try? It's quite frustrating to have shiny new components and not being able to install a simple Linux distribution on it.

Thanks!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.