1

I'm using a mostly clean Ubuntu 14.04 install.

I can mount the device successfully, using sudo mount -t ext4 /dev/sda4 /mnt/share. However, when I run sudo mount -a, I get the error

mount: wrong fs type, bad option, bad superblock on /dev/sda4,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail or so

Then, when I run dmesg tail I see:

EXT4-fs (sda4): Unrecognized mount option "fmask=0111" or missing value 

Looking at man mount, fmask should be a valid value. Here is the relevant line from /etc/fstab:

UUID=45099f0b-8d10-4fd7-8214-b0a070dc0be7  /mnt/share  ext4  errors=remount-ro,fmask=0111,dmask=0000  0  2

It may help to know that I believe this was working before I restarted the computer after installing some updates. (However, this is the first time I've restarted the computer since getting the mount up and running). Can anyone tell me what the problem here is?

3

You cannot use fmask and dmask with ext4 file systems. fmask and dmask is the permissions for files and directories to be assumed when the drive is mounted. Since ext4 supports permissions at file and directory level already, you do not have to provide it again. You can use these options for FAT volumes where you cannot specify such privileges. If you carefully read the man page for mount, you will find that even for NTFS you cannot specify these options (for a similar reason as ext4) but you can specify umask values.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.