9

I just created an Ubuntu 14.04 VM in VirtualBox (the host is Windows 7) and have noticed a strange "bug" occurring with the mouse. And yes I installed guest additions.

About 50% of the time, when I start the VM, it "registers" with my physical mouse, and when I mouseover the VM window, VBox correctly turns it into a "virtual mouse" on my Ubuntu desktop.

But about 50% of the time, something goes awry and as soon as I mouseover the VM window, my mouse just disappears. The only fix I've been able to find so far is to keep forcefully restarting the VM until I get lucky and the mouse registers/connects correctly.

What can I do to fix this?

  • I recommend starting the VM as headless and using VNC to connect to it. – user256743 May 12 '14 at 13:40
  • 2
    (1) Have you installed the guest additions and mouse integration is on? Try turning mouse integration off and let us know. (2) Is hardware acceleration on for the VM? Try also to turn it off. (3) What is the mouse driver in xorg.conf ? ("vboxmouse"?) – harrymc May 12 '14 at 13:40
6

There is a simple answer to this. VirtualBox latest guest addition 4.3.10 are still not fully compatible with Ubuntu 14.04. Screen auto-resizing issue, mouse pointer issue, shared clipboard issue and there are some others that occur intermittently with 14.04 VM.

Use Precise (12.04 Ubuntu) or wait for a new release of VBox to solve this issue.

| improve this answer | |
8

One suggestion I found was to "Just disable "mouse integration" in Machine tab.". Also on that page "Moving the Vbox window to my primary screen solved all issues." You can also toggle mouse integration from the lower-right corner of the guest:enter image description here

I also wonder if this is related or would be of help

The vboxvideo driver causes the mouse pointer to disappear

| improve this answer | |
  • 2
    This worked for me too: select Machine > Disable Mouse Integration, then select it again to re-enable. To clarify, the mouse was working before, I just couldn't see the cursor. Happens mainly when restoring from saved state. – Pie21 Apr 2 '15 at 12:53
4

I had similar issue (i.e. my mouse never showed up at all). None of the above solutions worked for me. What worked for me is select the VM by clicking and highlighting it in the VirtualBox. Then navigate to the "Settings". Click on the "Display" in the left pane. Then inside the "Video" tab, un-check "Enable 3D Acceleration". Apparently I had clicked on this checkbox that made my mouse pointer in VM disappear. Now boot the VM.

| improve this answer | |
  • This worked for me on OSX 10.11 as a host and Ubuntu 14.04.4 as a guest. – user2970139 May 5 '16 at 8:56
  • That fixes the "invisible pointer" problem, but with current Linux Mint 18.2, turning of 3d acceleration makes Cinnamon run in software rendering mode, which burns lots of cpu. There should be a way to keep the pointer and have 3d acceleration on. The VM pointer is visible at the login screen, an only vanishes after login as Cinnamon window manager starts up. – JesseM Oct 16 '17 at 19:24
0

I would, just for the heck of it try a different clicker and switch to a different port - that is PS2 if you have one, if you are using USB, and see what happens.

The headless solution is the best, it is going to separate hardware from software issue, probably definitively since your pointer is going to be really virtual, no hardware involved. If you do not have a second computer have someone with a laptop do it for you.

I am assuming you are using a USB mouse, I would be careful with sharing any USB data drive and let Ubuntu write to it just yet. If this is turning out to be more but a rendering bug VBOX might corrupt it.

| improve this answer | |
0

This happened to me too when I disabled mouse capture. The mouse cursor outside of virtualbox became stuck in one place (because I disabled it) and the new mouse pointer in virtual box becomes invisible. The best thing to fix this problem is to actually use an external device, such as a pc contoller with analog sticks. So, plug in your pc controller of whatever external device you want first, then download a free program called JoyToKey or something similar ( I would suggest JoyToKey, it works perfectly). Now, open JoyToKey and map your keyboard keys, like w,a,s,d or up, down, left, right and left and right mouse clicks, including middle mouse roll, and mouse movement axis (what you use to move a mouse, I mapped mine on my controller analog sticks to move pointer around) onto your pc controller. Next, open virtualbox (disable capture). This way, at least now you can move the pointer that was stuck initially in one place with your pc controller. So, if you want to use in Unity3d, open Unity3d now. Move your pointer using your external device, try to preview a game you made, and now you can look around using the mouse! Alternatively, disable hardware acceleration (drag slider to none instead of full) in Display options when inside virtualbox, (however this doesn't work if you want to use Unity3d, because the pointer still disappears when hovering over program)

| improve this answer | |
-2

Enter this code in ubuntu terminal to fix weird mouse issues in 14.04

sudo gsettings set org.gnome.settings-daemon.plugins.cursor active false
| improve this answer | |
  • 1
    Could you please explain what this actually does? – Mixxiphoid Jun 23 '14 at 6:18
  • 1
    Doesn't work for me. – David Doria May 13 '16 at 14:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.