0

I have a USB flash drive, which when I insert into my mac's USB port, shows up as two disks. One has a capacity of 2.11 GB, and has read/write privileges, the other has 2.1 MB capacity and is read only. I tired reformatting the 2.11 GB disk using disk utility, and making it have one partition, but that did not solve the issue.

The flash drive is not new, and I think the previous user of it did this. The read only disk also contains a .pdf file. Is there any way I could make it to show up as one disk with read and write privileges? I would like to keep it formatted as FAT because I need to use it with my mac and a pc running windows xp.

1

Some vendors (Sandisk comes to mind) make their flash drives appear to also be a CD-ROM, with "encryption" software or, in your case, some meaningless documentation. In the Disk Utility try removing/re-creating the entire partition table, then re-creating the FAT system. Some vendors make this even trickier where you need to visit their website and download a utility to remove this extra disk/partition and claim it as usable space in the main drive.

With the drive inserted, open a terminal screen and type mount [enter] if you see the disks listed as something like /dev/disk1s1 ... /dev/disk2s1 (differing disk#) then its a hardware/firmware issue with the drive itself, pointing the possibility of a utility from the manufacturer to consolidate it.
If you see /dev/disk1s1 ... /dev/disk1s2 (same disk#, differing s#) then the partitioning answers should have worked.

What is your brand/model USB flash drive?

7
  • Im not sure what brand it is, because it doesn't have a brand name on it. It has the logo of a company which was giving them out, but they don't make the flash drives themselves. – user3308082 May 11 '14 at 21:08
  • On your mac, go to [Apple] About this Mac, System/More Info, USB, and find the VendorID and ProductID of the USB drive in the list. they are both 4-digit values (ABCD or 0xABCD) – EkriirkE May 12 '14 at 0:07
  • when I open about this mac, and go to more info, I clicked on the "Storage" tab, and saw this: Imgur the top one is my internal hard drive, and the other two are from the flash drive. there was no USB section. – user3308082 May 12 '14 at 0:22
  • open a terminal window, with the drive plugged in type mount What do you see? – EkriirkE May 21 '14 at 5:45
  • /dev/disk0s2 on / (hfs, local, journaled) devfs on /dev (devfs, local, nobrowse) map -hosts on /net (autofs, nosuid, automounted, nobrowse) map auto_home on /home (autofs, automounted, nobrowse) /dev/disk1s1 on /Volumes/*name of read only disk* (msdos, local, nodev, nosuid, read-only, noowners) /dev/disk2s1 on /Volumes/*name of read and write disk* (msdos, local, nodev, nosuid, noowners) – user3308082 May 22 '14 at 2:28
-1

Use GParted (I recommend it) or the Windows Disk Management Tool (right click on Computer → Manage... → Hard drives) to remove the extra partitions and resizing the first one to occupy the free space and your problem is solved.

6
  • -1 This is a firmware issue. – kinokijuf May 11 '14 at 6:30
  • Are you completely shure? I've had about 3 or 4 sticks with that extra partition and creating a new partition table solved the issue. Also rounding to cylinder/MiB when creating a partition may leave some trailing free space. – arielnmz May 11 '14 at 6:37
  • The OP indicated that it shows as two separte drive, U3-style. – kinokijuf May 11 '14 at 6:38
  • I don't know what U3-style stands for but doesn't ejecting one drive would eject the other "drive" as well? If that is the case then it may just be, as I said, just another partition of the same device displayed as another drive (e.g. Thunar under my Fedora 20 box displays every partition as a different drive, however ejecting one would eject all the partitions of the same device as well, and it is perfectly normal) – arielnmz May 11 '14 at 6:47
  • @arielnmz If I eject one drive, the other one does not automatically eject, and I can still open it in finder – user3308082 May 11 '14 at 21:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.