6

I'm using virtualbox with Kali and it's working fine, however I currently only have it using 1 cpu and I'd like to add more.

However when I go to Settings → System → Processor the fields are greyed out and I can't change number of processors (this happens even when kali isn't running). Any help is appreciated

1
  • restart, close all processes related to virtualbox of vbox and then open vbox and then try to change. – Hunter May 12 '14 at 4:33
7

You can find the workaround here: How do I enable multiple cores in my virtual enviroment?.

To enable more than 1 CPU in your VM the following settings are needed in addition:

  • 64-bit virtual guest hardware in General settings tab (for 64-bit guests)

  • Enable I/O APIC in the Motherboard settings tab

  • Enable hardware virtualization (VT-x/AMD-V) in the Acceleration tab

Note that if your run your VM on all cores available you may experience a better host performance when assigning an execution cap to the CPU.

You won't be able to edit the CPU count while the VM is running or has a saved state, so make sure that it is in the powered off state.

1
  • What if the accelaration tab is grayed out too ? – user2284570 Feb 25 '17 at 22:13
0

I had a similar issue: I could not change the number of processors or the amount of RAM after I had run a new VM and installed a host OS.

The only way I found was to create a brand new virtual machine using all the new settings I want and then instead of creating a new virtual hard drive just link the drives from the first VM. As long as you make the MAC address the same as the old one it all works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.