16

I have a dual screen set-up. I'm running windows 8.1. I have had this issue with Management studio 2008 R2, 2012 and 2014.

If I drag the management studio screen across to my 2nd display, and then close it down, when I open it again, it opens on the 2nd display. This is what I would expect. Unfortunately, the connect to server dialogue box is hidden from view and the main screen remains out of focus. It remains unresposive, waiting for the dialog that can't be found. I have tried ctrl-alt-tab and ctrl-alt-esc to find it but to no avail.

The only way I can sort it is to kill off the process. switch to single screen and then open it.

Does anyone know of a fix for this behaviour. Its really frustrating.

migrated from stackoverflow.com May 12 '14 at 15:45

This question came from our site for professional and enthusiast programmers.

  • This is atypical behavior for SSMS. I have used it on many machines with dual monitors and never experience this issue. Do you have some third-party multi-monitor software installed? Perhaps the software is configured to remember relative locations of dialog boxes when they open, or something? Have you tried dragging SSMS to the 2nd monitor, closing SSMS, re-opening it, and see what happens? – Max Vernon May 12 '14 at 17:50
  • 1
    No there is no third party software. I cannot drag the SSMS window as it is completely unresponsive because the 'connect to server' dialogue box is hidden somewhere. – Lee Chetwynd May 13 '14 at 7:55
  • My colleagues also experience the same issue. I have tried different versions of management studio (see in question), to see if it is fixed (I think is a bug). – Lee Chetwynd May 13 '14 at 7:57
  • As a work-around, try opening SSMS on the main screen, connecting to a SQL Server, then drag the open Window to the 2nd screen. Close SSMS. Re-open it, and see if that resolves the issue. – Max Vernon May 13 '14 at 14:00
  • What you have described doing is the actual problem that I have. I drag SSMS onto my second screen, close it, when opened again, it will always open on the 2nd screen. That is the problem, it hangs there. It works fine on a 2nd screen until I close it on the 2nd screen. Then there is no way of re-opening it without killing it off, through task manager, switching to single display and opening it again. – Lee Chetwynd May 13 '14 at 14:11
30

I have found the answer on the server fault site:

https://serverfault.com/a/491235/171795

Unfortunately I can't vote the guy up (https://serverfault.com/users/166318/eirik-toft) as I don't have any reputation on that site (or this site that my question got migrated too) However, I thought I would leave this answer here as a signpost to his answer.

To work around the issue I 'alt-tab' to select the main sql window. Then 'alt-space' to get the context menu then 'm' to select move, then I used the arrow keys to brings the hidden dialogue box into view.

  • 4
    I have discovered a little more information that may be helpful. This problem occurred because my dual screens were not level. My second screen was to the right and lower than my primary screen. I had configured this in the screen resolution settings so the pointer flowed from one to the other correctly. The connection dialog for SQL MS tries to appear in the centre level with the primary display and therefore off screen. – Lee Chetwynd Oct 14 '14 at 9:37
4

It might be a bit late for this but I suffered from the same problem. Happens to me when I close it on the second monitor with it attached at the corner. The simple solution to me was to just hitting escape with the focus being on the Manager. That closes the dialog so you can control the manager again. Then move it to the main monitor and try to connect. A lot simpler then trying to move the dialog into focus.

1

Thanks for the answers here guys!

It helped me to find a permanent solution when using a dual screen setup.

After you've managed to get the Object Explorer back on the screen you can close it and configure Management Studio (2014) to not open it automatically during startup. This will prevent the phenomenon from occurring when Management Studio is set to open on your secondary screen automatically.

Do so by going to Tools > Options > Environment > Startup

For the option "At startup:" select "Open empty environment", click "OK" and you're rid of this annoyance. :-)

  • After further investigation I found that the above is not a permanent fix to the problem. I did find the root cause on my system and managed to fix this permanently. On Windows 8.1 the multiple screen layout alignment causes this problem when not aligned to either the top or bottom. I've snapped my screens to their top boarder and this completely solved this issue for me irrespective of changing the startup options. :-) – Stephen Mar 14 '16 at 7:34
0

You may simply "Lock the screen" (Win-L) then login back to the Windows, you should see the dialog box appears. It is definitely a problem with more than one screen in which any one of them is not set to the same level (not aligned to (0,0)) therefore the dialog box is hidden.

0

Other solutions were not working for me, as I just couldn't get the window to show up.

However, if you press "enter" right after you start it up, you are pressing "enter" on the connection window which is in focus (but off screen) and it will re-connect to your last entry.

So at least if your last is valid, this is a temporary workaround.

-1

I was able to fix the issue of the dialog being out of the screen space by doing the following:

  • Configure my displays so that only one was active
  • Log out of Windows
  • Log back in and open SQL Management Studio
  • Restore the multi-monitor configuration

I also tried the old trick of using the windows key with arrow keys to try and move the dialog to another screen but that doesn't work in this case.

-1

change resolution of the display to make the screen where SSMS is currently frozen the main screen. This will unfreeze SSMS

-1

In my case, "Run as Administrator" option worked like charm. I was accessing my server screen with the windows RDP. And when I open SQL Server Management Studio and Visual Studio 2010 user hangs at the moment and wont operate unless sign off r disconnected by administrator.

But when I set compatibility mode of both the application to the "run as Administrator", it starts working fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.