Is there a way to set a default homepage for a Wifi Network, maybe tweaking the router configuration? My router is TP-Link TL-WR541G.

I mean, when someone just connects to the wifi and first open the browser.

Chillispot is a close solution. However, I only need to redirect WLAN hosts to a public web page when they open the browser for first time, not for login or revenue stuff.

  • The site structure relies on questions containing just the question and solutions being in answer posts. Your solution was moved to an answer. If you accept that (or any other answer), that will signify that the issue has been solved.
    – fixer1234
    Oct 7, 2017 at 19:37

4 Answers 4


You'll want/need to implement a captive portal. See here for a description:


  • This is what I was looking for. The magic of superuser.
    – conner.xyz
    Jun 3, 2019 at 20:40

In order to route my Wi-Fi traffic to a local web page which shows :

Yes, it works!

,I am using Linux IPTABLES:

#iptables -t nat -A OUTPUT -p tcp -j DNAT --to

As far as I know, this functionality can only be provided by the router that provides the actual gateway to the web. Consumer-grade routers generally don't provide this functionality.

However, some inexpensive consumer-grade routers can have their firmware replaced with something much more powerful. DD-WRT is one example. Unfortunately, it appears that your specific router isn't supported.

If you choose to get a different router and play with DD-WRT, then you can set up a Captive Portal using Chillispot.

Good luck :)

  • thanks for the info! I read a little about captive portals, that's seems the option, although I don't need any authentication
    – autorun
    May 13, 2014 at 5:17
  • Hello again. I'm about to install DD-WRT on a compatible router. I'll try Chillispot, but I must say I just want the browser to redirect to a public web page, not for login or revenue stuff. Do you think it will be possible using some captative portal?
    – autorun
    Sep 4, 2014 at 1:31

Posted by the OP in the question and moved to an answer post:

I've solved it using NoDogSplash installed on OpenWRT. Both are very easy to configure. If you're stucked in this, give it a try!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .