I have following setup: OS Ubuntu/Gnome, 1 TB external drive, created and encrypted (whole disk encryption) on Windows7. On this encrypted partition I have a 80 GB Truecrypt Container.

My system froze when it was copying data to this mounted, encrypted container. Now I am able to mount and access data on the encrypted drive, I see the encrypted container but I can't mount it, nor repair it in any way. When trying to mount it with TC I get: "$MFTMirr does not match $MFT (record 0). Failed to mount '/dev/mapper/truecrypt9': Input/output error" I cannot do any ntfsfix on since it is not a real device to get access to ...

1 Answer 1


I came across the same issued and solved using the following steps:

  1. selected the container to mount as usual clicking on the "Select file" button
  2. once selected the container file hit I clicked on the "Mount" button
  3. in the password input popup I clicked on the "Option" button
  4. in the full option popup I checked the radio box "Do no mount" in the filesystem frame at the bottom of the page
  5. type the password and clicked on the "Ok" button
  6. at the shell prompt I issued the following command: sudo ntfsfix /dev/mapper/truecrypt9 please note that the proper device depends on the slot selected for the container mount (truecrypt9 is for slot 9) and this was the output of the command:

Mounting volume... $MFTMirr does not match $MFT (record 0).


Attempting to correct errors...

Processing $MFT and $MFTMirr...

Reading $MFT... OK

Reading $MFTMirr... OK

Comparing $MFTMirr to $MFT... FAILED

Correcting differences in $MFTMirr record 0...OK

Processing of $MFT and $MFTMirr completed successfully.

Setting required flags on partition... OK

Going to empty the journal ($LogFile)... OK

NTFS volume version is 3.1.

NTFS partition /dev/mapper/truecrypt9 was processed successfully.

  1. went back to truecrypt window unmounted the container and mounted as usual and it worked
  • I had same issue but with an encrypted device, not a container and this worked for me as well! Thanks Jan 24, 2016 at 5:14

You must log in to answer this question.