1

I am using putty to connect to my linux server and if I open any files with vim or vi editor the editor margins are getting limited, whereas the same full screen is coming if I open in XTERM. My desktop screen is having 1280 X 1024.

2

You probably have :set lines=N columns=M commands that do the resizing. Unfortunately, not all terminals support the dynamic resizing. Apparently, PuTTY doesn't. I also tried

$ stty columns 120

directly in the terminal, also with no effect.

With PuTTY, you can work around this by manually putting its window to fullscreen (e.g. by double-clicking on the titlebar).

  • Yes , I already used set lines & columns but it is not giving properly some times. I was looking if there is any vim configuration which can be used. Because each and every time setting that option may become difficult. – Sriharsha Kalluru May 15 '14 at 11:03
  • After removing set lines=68 from my .vimrc, no problem anymore with the display in PuTTY. – Olivier Faucheux Jun 24 '15 at 8:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.