1

I have a small problem. I have several kiosk stations that I created, and I cannot run anything as an administrator because the password is expired. We created an administrative user account specifically for our department to use and I neglected to check the 'password never expires' option for the account, so the password has expired. The built in administrator account is disabled. Thus I can't do any installs or run anything to get the machine OUT of kiosk mode (the machine automatically logs in as a limited user). Here's what I've tried, each has failed:

  • Lock system and switch user (on the kiosks locking the workstation is disabled. Also, the ForceAutoLogon setting is set to 1 in the registry so clicking switch user logs back in automatically, and I can't change ForceAutoLogon to 0 since I can't run regedit elevated).
  • Boot from install CD and choose repair. Tried to use the repair command prompt to activate Administrator account or to change password for the other administrator account (net user commands...). This fails, it seems to only affect accounts for the version of Windows in memory not the one on the hard drive, the other administrator account isn't recognized.
  • Safe Mode. Autologon happens with safe mode as well so I still don't have the opportunity to change the password, and since it autologs in as a limited user, I still can't run elevated applications.
  • I can't login to the system with the administrator account to have it prompt to change password as the computer is set to automatically login as a limited user and I can't turn off these settings without running regedit as an administrator.

The operating system is Windows 7 64 bit.

Any suggestions no how to get around this issue?

  • try to boot Windows in Safe mode (power off, power on and F8 in several boot menu's, choose Safe mode). Is Windows automatic logon then? If not, you should be able to access the Administrator account. – Dave May 15 '14 at 15:36
  • Yes, Automatic logon happens then as well, sorry I forgot I tried that as well when I made my list of things I tried. I edited the Q to reflect. – yougotiger May 15 '14 at 15:44
  • Use the tool of your choice to either enable the default Administrator account or change the password on the existing account.I suggest this tool – Ramhound May 15 '14 at 16:08
  • @yougotiger Hold down the Shift button before the logon screen appears, and until it finishes loading. If done right, the automatic logon should be canceled. – and31415 May 15 '14 at 22:16
  • I may have disabled that on some of the kiosks, it's possible via the local group policy. Actually looks like it's a registry edit to disable that and I believe I have. I'll give it a try and report back. – yougotiger May 15 '14 at 22:24
0

Here's what I found solved the issue. I downloaded the 'Ultimate Boot CD' (http://www.ultimatebootcd.com/) which allowed me to boot to their Linux cd, and then used the included PCRegedit utility to change the registry so that the computer logged in as the administrator user with the expired password. When it automatically logs in, since the password is expired, you are required to change it. Now I'm logged in as an administrator and can run computer management utility and set the admin user's password to never expire. I then boot from the ultimate CD again, and then change the registry to have the limited user login automatically once again. Kind of a lot of waiting as things boot round and round again, and it has to run chkdsk every time you use the PCRegedit tool, but it works.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.