0

How do you stop Firefox from always opening an HTML document? I downloaded an HTML practice file and must have chosen Firefox to "always open the file". Now when I right-click on the file, the only option is to "open" and there is no option to "open with." I would like to have the file in its original form (like when I first downloaded it) but if I had to choose a program to open it with, I would change it to Notebook++. I have tried deleting the file, but when I re-download it, the computer remembers that it is Firefox that I chose to open it with the last time.

Thanks!

  • 2
    What OS are you using? – user304064 May 15 '14 at 18:25
  • 1
    What operating system? This is done differently on each. – Moses May 15 '14 at 20:45
2
  • Control Panel > Programs > Default Programs > Associate a file type or protocol with a program

  • Or simply copy paste Control Panel\Programs\Default Programs\Set Associations into your control panel navigation bar.

.html (.htm) - Choose your preferred program to associate with HTML files.

enter image description here

Larger Image

0

You can set the file association:

Right Click > Properties > Change

Navigate to your notepad++.exe and select it to open the file. Apply the settings and all should be well.

EDIT: Assuming Windows OS here. If mistaken I will edit my answer. Just on the off chance though.

0

Right click on the HTML file and select properties.

There should be a button that reads "Change".

Click the button to change what program opens the HTML file.

This is only for Windows operating systems.

  • I am using Windows OS. When I right click and go to properties, the only clickable buttons at the bottom of the window are ok and cancel. There are no other tabs in properties except for "general". the type of file is: firefox HTML document. I don't see a "change" button. – user323167 May 16 '14 at 15:55
  • I see on other files where the "change" button is present, but it's not on this one. It's like Firefox has claimed it and not allowing any changes – user323167 May 16 '14 at 16:56
  • It sounds like you may be clicking on a shortcut instead of an actual HTML file. – Sorean May 16 '14 at 19:18
0

The following website provides the perfect answer nixstudio.com:

Control Panel > Programs > Default Programs > Make a file type always open in a specific program.

Locate the file type you want to change. for example .html and highlight it. On the right hand side click on change program then select your favorite program then voila you can now open this file type with your favorite and most importantly PREFERRED program!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.